Opened 13 years ago

Last modified 9 years ago

#653 closed defect (invalid)

mplayer crashes when trying to play large (>4GB) file

Reported by: axos88@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Windows XP, SP2.
A try to play a large (4 958 157 312 B) file, but mplayer freezes at this point:
(Have a batch job so that i don't have to enter mplayer's path every time from cmd)

C:\DOCUME~1\Akos>call "c:\program files\mplayer\mplayer.exe"
d:\Images\Video01.avi
MPlayer 1.0rc1-3.4.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection.

Playing d:\Images\Video01.avi.
AVI file format detected.
Terminate batch job (Y/N)? Y

MPlayer interrupted by signal 2 in module: demux_open
AVI: Missing video stream!? Contact the author, it may be a bug :(

Opening it with Windows Media Player works OK. But i don't like it. Wanna use
MPlayer :)

Change History (4)

comment:1 Changed 13 years ago by compn

  • op_sys changed from Other to MinGW
  • Priority changed from important to normal
  • Severity changed from major to normal
  • Version changed from 1.0rc1 to HEAD

known bug, mingw mplayer does not have large file support.

workaround: use a cygwin built mplayer to read >4 gb files.

comment:2 Changed 13 years ago by reimar

Try -idx, -noidx, -forceidx. One of those might work for AVI files (though it
is still uncertain how much of the file it will play).

comment:3 Changed 13 years ago by compn

i think building mplayer with this patch for mingw will fix at least some of the
problem.

http://oss.netfarm.it/mplayer/misc/file64_mingw.diff
but the mplayer i built was unable to seek, so i'm not sure...

comment:4 Changed 9 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed, patriotact@gmail.com

that mingw patch works for me now, so closing this bug.

also marking as invalid as this is a mingw problem and they really need to fix it.

Note: See TracTickets for help on using tickets.