Opened 12 years ago

Closed 11 years ago

#664 closed defect (worksforme)

MPlayer crashes when playing streamed video

Reported by: hylke.donker@… Owned by: r_togni@…
Priority: important Component: streaming
Version: HEAD Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I try to play the video from
mms://topstreams.omroep.nl/tv/bnn/delamas/bb.20061110.asf by executing:
mplayer mms://topstreams.omroep.nl/tv/bnn/delamas/bb.20061110.asf
MPlayer crashes.
Here's the output I get:
-- Begin Output --
CPU: AMD Athlon(TM) XP 2800+ (Family: 6, Model: 10, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Playing mms://topstreams.omroep.nl/tv/bnn/delamas/bb.20061110.asf.
STREAM_ASF, URL: mms://topstreams.omroep.nl/tv/bnn/delamas/bb.20061110.asf
Resolving topstreams.omroep.nl for AF_INET6...
Couldn't resolve name for AF_INET6: topstreams.omroep.nl
Resolving topstreams.omroep.nl for AF_INET...
Connecting to server topstreams.omroep.nl[145.58.33.69]: 1755...
Connected
file object, packet length = 2888 (2888)
unknown object
unknown object
unknown object
unknown object
stream object, stream ID: 1
stream object, stream ID: 2
stream object, stream ID: 3
stream object, stream ID: 4
unknown object
unknown object
data object
mmst packet_length = 2888
Cache size set to 64 KBytes
Cache fill: 0.00% (0 bytes)
ASF file format detected.
VIDEO: [WMV2] 352x264 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
Clip info:

name: De Lama's (NEDERLAND 3, 22:15, vrijdag 10 november 2006)
author: BNN
copyright: (c) 2006, BNN

==========================================================================
Opening video decoder: [dshow] DirectShow? video codecs
Decoder supports the following YUV formats: YUY2 IYUV UYVY YV12 YVYU I420 YVU9
Decoder is capable of YUV output (flags 0x7f)
VDec: vo config request - 352 x 264 (preferred colorspace: Packed YUY2)
[PP] Using codec's postprocessing, max q = 4.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 352x264 => 352x264 Planar YV12
Selected video codec: [wmv8] vfm: dshow (Windows Media Video 8)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 32.0 kbit/2.26% (ratio: 3995->176400)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...

MPlayer interrupted by signal 11 in module: decode_video

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

-- End Output --

MPlayer crashes with almost any stream from that website. So it's not related to
that perticular file.

Change History (5)

comment:1 Changed 12 years ago by hylke.donker@…

Oh, and I forgot to mention that i've compiled MPlayer(which i've downloaded
just a few minutes ago with SVN) with the following arguments passed to configure:
--enable-gui --enable-menu --enable-gl

comment:2 Changed 12 years ago by compn

can you try -vc wmvdmo

comment:3 Changed 12 years ago by hylke.donker@…

(In reply to comment #2)

can you try -vc wmvdmo

It works if I do that. But it's very slow untill I get the following message:

-- Begin Output --


Your system is too SLOW to play this!

Possible reasons, problems, workarounds:

  • Most common: broken/buggy _audio_ driver
    • Try -ao sdl or use the OSS emulation of ALSA.
    • Experiment with different values for -autosync, 30 is a good start.
  • Slow video output
    • Try a different -vo driver (-vo help for a list) or try -framedrop!
  • Slow CPU
    • Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts, e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
  • Broken file
    • Try various combinations of -nobps -ni -forceidx -mc 0.
  • Slow media (NFS/SMB mounts, DVD, VCD etc)
    • Try -cache 8192.
  • Are you using -cache to play a non-interleaved AVI file?
    • Try -nocache.

Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.
-- End Output --

comment:4 Changed 12 years ago by compn

well it sounds like the wmv8 or dshow codecs are crashing on your system.

what is the md5sum of your wmv8ds32.ax

f442cbb79dd3682fbe6377221522f72f *d:
cdrive
mplayer
wmv8ds32.ax

comment:5 Changed 11 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

closing, works for me

Note: See TracTickets for help on using tickets.