Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#669 closed defect (invalid)

mplayer doesn't show subtitles from matroska v2(simple blocks)

Reported by: yaroslav.isakov@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

i create matroska v2 file with srt subtitles, but when i play this in mplayer,
it show me the bunch of errors

Warning: No BlockDuration? for subtitle track found

and doesn't show subtitles at all

Change History (10)

comment:1 Changed 13 years ago by compn

got a sample?

comment:2 Changed 13 years ago by yaroslav.isakov@…

I upload 2 files (begins with "bug669-") to upload.mplayerhq.hu/MPlayer/incoming
there is one v2 (didn't show subtitles) and v1 (show subtitles)

comment:3 Changed 13 years ago by yaroslav.isakov@…

dis this in mmg from mkvtoolnix-1.8.1

comment:4 Changed 13 years ago by compn

  • op_sys changed from Linux to All
  • Version changed from 1.0rc1 to HEAD

tested with svn mplayer. do you know if this file works with other video
players?

[mkv] Track ID 1: video (V_MS/VFW/FOURCC), -vid 0
[mkv] Track ID 2: subtitles (S_TEXT/UTF8), -sid 0, -slang und
[mkv] Will play video track 1.
[mkv] Will display subtitle track 2.

some of these errors:
dvdsublang...bug669 simpleblocks und

comment:5 Changed 13 years ago by yaroslav.isakov@…

Hmm... I test this on Windows in Zoom Player and Light Alloy with latest Haali
splitter, and it doesn't work, too (vsfilter doesn't show subtitles) Maybe it's
a bug in mmg/mkvmerge? Or it's a new feature (v2) and it's not properly realized?

comment:6 Changed 13 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed

could be a bug, or unsupported yet, or both! :)

i'm gonna mark this invalid, until other players start supporting v2
or until you get a sample that plays properly.

comment:7 Changed 13 years ago by yaroslav.isakov@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

Sorry, but I need to reopen this bug because today I compile vlc-0.8.6 and it show
subtitles very well (sample files too)

comment:8 Changed 13 years ago by eugeni.stepanov@…

  • Resolution set to invalid
  • Status changed from reopened to closed

The v2 sample lacks block duration information for subtitles, and cannot be displayed correctly. With this file, mkvextract produces a .srt where all subtitles have zero duration.
It seems like a bug in mkvtoolnix 1.8.1.
VLC simply displays each subtitle until the beginning of the next one. That's not a solution at all.

comment:9 Changed 13 years ago by yaroslav.isakov@…

I post a bug in bugzilla of mkvtoolnix developer https://www.bunkus.org/bugzilla/show_bug.cgi?id=215

Note: See TracTickets for help on using tickets.