Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#68 closed defect (worksforme)

Bad Audio

Reported by: x-files@… Owned by: alex@…
Priority: normal Component: af
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When a reproduce this file
ftp://ftp.mplayerhq.hu/MPlayer/incoming/quicktime_audio_bug.mov the sound is
bad!!! It sound snoze!

X:\Programas Genericos\Mplayer\winmplayer\mplayer>mplayer
x:\samples\quicktime_audio_bug.mov
MPlayer dev-CVS-040829-00:14-3.3.1 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon Thunderbird 1148 MHz (Family: 6, Stepping:
2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or
directory
Reading config file X:/Programas
Genericos/Mplayer?/winmplayer/mplayer/mplayer/config
Reading X:/Programas Genericos/Mplayer?/winmplayer/mplayer/mplayer/codecs.conf:
Can't open 'X:/Programas Genericos/Mplayer?/winmplayer/mplayer/mp
Reading /usr/local/etc/mplayer/codecs.conf: Can't
open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
c:/windows/fonts/arial.ttf doesn't look like a font description, ignoring
Cannot load font: c:/windows/fonts/arial.ttf
Using Windows native timing
Input config file X:/Programas
Genericos/Mplayer?/winmplayer/mplayer/mplayer/input.conf parsed: 53 binds

Playing x:\samples\quicktime_audio_bug.mov.
QuickTime?/MOV file format detected.


MOV track #0: 763 chunks, 763 samples
Image size: 640 x 480 (24 bpp)
Display size: 640 x 480
Fourcc: jpeg Codec: 'Photo - JPEG'


MOV track #1: 26 chunks, 0 samples
Audio bits: 16 chans: 1 rate: 7840
Fourcc: twos


MOV: longest streams: A: #1 (26 samples) V: #0 (763 samples)
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 7840 Hz, 1 ch, 16 bit (0x20), ratio: 15680->15680 (125.4 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmjpeg] vfm:ffmpeg (FFmpeg MJPEG decoder)
==========================================================================
Checking audio filter chain for 7840Hz/1ch/16bit -> 7840Hz/2ch/16bit...
AF_pre: af format: 2 bps, 1 ch, 7840 hz, big endian signed int
AF_pre: 7840Hz 1ch Signed 16-bit (Big-Endian)
AO: [win32] 7840Hz 2ch Signed 16-bit (Big-Endian) (2 bps)
Building audio filter chain for 7840Hz/1ch/16bit -> 7840Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar 422P)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar 422P as output csp (no 1)
Movie-Aspect is undefined - no prescaling applied.
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 1
SwScaler?: reducing / aligning filtersize 9 -> 8

SwScaler?: BICUBIC scaler, from Planar 422P to Planar YV12 using MMX2
VO: [directx] 640x480 => 640x480 Planar YV12

Exiting... (Quit)

Change History (2)

comment:1 Changed 15 years ago by r_togni@…

Please explain "snoze".
File plays ok imho, and plays the same with all the players i tester (MPlayer,
xine, vlc).

Sound it's distorted, but i don't think that's caused by mplayer. Else every
linux player have the same bug.

If someone can test it with qt on win please comment.

comment:2 Changed 15 years ago by r_togni@…

  • Resolution set to worksforme
  • Status changed from new to closed

No replay from the bugreporter in 2 weeks.
So, bug closed as worksforme.

Ciao,

Roberto

Note: See TracTickets for help on using tickets.