Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#687 closed enhancement (fixed)

srt timing problem, half subtitles are missings

Reported by: zigziggy175@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc1 Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When playing the srt file I provide as link, the timings are wrong which make
captions stay on screen for too long, and subsequently some captions (about
half of them) are missing. When you look at the file, the timings are correct
and there isn't any overlapping, also the file works with xine without
problems.

The bug also happens with 1.0pre8 and probably even earlier (it's not the
first time I encountered this bug in fact) What this srt has special is that I
produced it myself using subtitleripper. However I don't see anything special
with it and I don't understand why many captions aren't displayed since there
aren't any overlapping in the timings.

Attachments (1)

ifp-utf8.srt (159.0 KB) - added by zigziggy175@… 13 years ago.
The problematic srt file (in case of the link I provided doesn't work)

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by zigziggy175@…

The problematic srt file (in case of the link I provided doesn't work)

comment:1 Changed 13 years ago by zigziggy175@…

comment:2 Changed 13 years ago by zigziggy175@…

Ok, I tried the option -overlapsub and with that option, it almost works
except that all captions are now displayed twice ! There's something seriously
screwed up here ...

The timings are now all good and I don't miss any captions, but I get the text
repeated twice ...

comment:3 Changed 13 years ago by reimar

  • Severity changed from major to enhancement

There is no overlapping you say?

1126
01:52:11,710 --> 01:52:14,060
Sous-titrage = C.M.C. - Paris

1127
00:00:51,420 --> 00:00:55,929
ivre de femmes et de peinture (au fiI de la vie)

I say there is not only overlapping but actually heavy breakage. The timestamps
were created to fit the MPEG timestamps, which on DVDs can be essentially
random instead of the real playback time... Though I have some doubts it will
work right even if you fix this, without also fixing the DVD.

comment:4 Changed 13 years ago by zigziggy175@…

  • Resolution set to fixed
  • Status changed from new to closed

ok, thanks, indeed the mistake was in the srt file, my apologies :)

In fact, the subtitles are ripped twice in that file, I only needed to remove
the second half and it works perfectly.

So it's subtitleripper that needs to be fixed, though the problem isn't
difficult to work around ...

Note: See TracTickets for help on using tickets.