Opened 12 years ago

Closed 8 years ago

#694 closed defect (duplicate)

Error while parsing chunk header

Reported by: diego@… Owned by: reimar
Priority: normal Component: streaming
Version: HEAD Severity: normal
Keywords: Cc: compn, skliarie@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The URL mentioned in the URL field fails to play even with -playlist. "Error while parsing chunk header" appears in the output throughout. This was first reported as a Debian bug, compare

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=403646&repeatmerged=yes

Change History (7)

comment:1 Changed 12 years ago by r_togni@…

  • Status changed from new to assigned

That error message is unrelated.
It's a playlist in playlist, but -playlist switch can force playlist parsing only for the first case.
The mimetype from the server is video/x-ms-asf for both first (the asx) and second (the makeplaylist.dll) playlists (that's not a playlist mimetype, but this is sadly quite common for wmv). Because of this the seconf file is processed by so the file is processed by the asf demuxer, and that obviously fails.

Imho the only clean way to fix this is to restore automatic playlist detection (eventually enhanced).

A temporary workaround is to change the #if 0 at line 4281 in mplayer.c to #if 1 (this needs some checks before we can think about changing it in svn).

comment:2 Changed 12 years ago by diego@…

What were the problems with playlist autodetection? Do they still apply? Having to manually specify -playlist is ugly.

comment:3 Changed 12 years ago by m.euer@…

Sirs !
I find that MPlayer-1.0rc can't handle .asx Urls like: http://www.wbur.org/listen/feed/shoutcast.asx with the errors described above.
I found that MPlayer-0.93 had no problems with those !
Maybe this can be of help to you?

comment:4 Changed 9 years ago by skliarie@…

  • Cc skliarie@… added

3.5 years later - is there hope for the bug to be fixed?
I got here because people I installed ubuntu for can not play videos from an high-profile site:
http://www.hidabroot.org/MediaDetail.asp?MediaID=11886

What is the problem to enable playlist autodetection for nested links as well?

comment:5 Changed 9 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:6 Changed 9 years ago by compn

  • Cc patriotact@… added

probably no fix, playtree / playlist is some of the oldest (and buggiest) code in mplayer.

comment:7 Changed 8 years ago by diego@…

  • Resolution set to duplicate
  • Status changed from assigned to closed

Mark this as a duplicate of a more general automatic playlist detection bug.

Note: See TracTickets for help on using tickets.