Opened 13 years ago

Closed 12 years ago

#708 closed defect (invalid)

DirectFB output will not be build with --enable-directfb

Reported by: schleinzer@… Owned by: beastd
Priority: normal Component: vo
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

If you set the --enable-directfb the configure script will not search for the directfb header files. It will just complain that directfb.h has not been found and not compile directfb output

I fixed that by searching for the header files the same way configure tries to figure them out if no option has been set

Attachments (1)

mplayer-1.0-directfb.patch (581 bytes) - added by schleinzer@… 13 years ago.
mplayer-1.0-directfb.patch

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by schleinzer@…

mplayer-1.0-directfb.patch

comment:1 Changed 13 years ago by schleinzer@…

This will just add a way to search for the right header files when --enable-directfb is specified. This is needed on gentoo boxes to compile mplayer correctly

comment:2 Changed 12 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

As configure states multiple times, whoever uses --enable flags is on his own, and current behaviour is as intended.

Note: See TracTickets for help on using tickets.