Opened 12 years ago

Closed 12 years ago

#711 closed defect (worksforme)

Problems playing FFMPEG generated AVIs

Reported by: john.sergeant@… Owned by: mans@…
Priority: normal Component: libavformat
Version: unspecified Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

AVI re-compressed using Motion JPEG will not play on Windows Media Player
*or* WinAmp? (although MPlayer works ok). Example :

mencoder -oac -ovc lavc vcodec=mjpeg:mbd=2:turbo=1 in.avi -o out.avi

This seems to be caused by the extradata_size being added to the strh BITMAPINFOHEADER structure size field in put_bmp_header(...) in riff.c -if the structure size is set back to 40 with a hex editor the AVI file will play in all players that I have tried.

Attachments (2)

test_duff.avi (138.8 KB) - added by john.sergeant@… 12 years ago.
MJPEG compressed AVI created using ffmpeg + mencoder
test_ok.avi (138.8 KB) - added by john.sergeant@… 12 years ago.
Same AVI with byte at offset 0xAC changed to 0x28

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by mans@…

Please upload a sample.

Changed 12 years ago by john.sergeant@…

MJPEG compressed AVI created using ffmpeg + mencoder

comment:2 Changed 12 years ago by john.sergeant@…

Changed 12 years ago by john.sergeant@…

Same AVI with byte at offset 0xAC changed to 0x28

comment:3 Changed 12 years ago by john.sergeant@…

comment:4 Changed 12 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

closing all ffmpeg bugs

C:\mplayer>mencoder -nosound -ovc lavc -lavcopts vcodec=mjpeg:mbd=2:turbo=1 -o o
ut.avi vid00009.avi

works for me in wmp using morgan mjpeg codec to decode.

if ffmpeg still creates unplayable files, please make a new report at ffmpegs roundup tracker

Note: See TracTickets for help on using tickets.