Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#733 closed defect (invalid)

FIOS router drops connection for real audio stream

Reported by: oliynykko@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have Verizon FIOS with Actiontect, Model Name: MI424-WR, Firmware Version: 4.0.16.1.45.120 router provided by Verizon.

I have second router - devil linux, with linux and windows computers behind it.
My router ip (broadband) 71.172.56.140
Internal router (devil linux) 192.168.200.2

I can listen on windows computer Real Audio stream using real audio internet explorer plugin or download it using FlashGet?, http://www.flashget.com

But mplayer on linux computer cannot setup connection, this is the console output, I turned LOG on for in real.c:

=====================================================================
...
[root@linux cartalk]# mplayer -v -dumpstream rtsp://rx-wes-sea120.rbn.com/farm/*/cartalk/cartalk/demand/CT0704-10.ra
MPlayer 1.0rc1-3.2.2 (C) 2000-2006 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Model: 8, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE
get_path('codecs.conf') -> '/root/.mplayer/codecs.conf'
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine?: '-v' '-dumpstream' 'rtsp://rx-wes-sea120.rbn.com/farm/*/cartalk/cartalk/demand/CT0704-10.ra'
init_freetype
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using nanosleep() timing
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
get_path('CT0704-10.ra.conf') -> '/root/.mplayer/CT0704-10.ra.conf'

Playing rtsp://rx-wes-sea120.rbn.com/farm/*/cartalk/cartalk/demand/CT0704-10.ra.
get_path('sub/') -> '/root/.mplayer/sub/'
STREAM_RTSP, URL: rtsp://rx-wes-sea120.rbn.com/farm/*/cartalk/cartalk/demand/CT0704-10.ra
Filename for url is now rtsp://rx-wes-sea120.rbn.com/farm/*/cartalk/cartalk/demand/CT0704-10.ra
Filename for url is now rtsp://rx-wes-sea120.rbn.com/farm/*/cartalk/cartalk/demand/CT0704-10.ra
Resolving rx-wes-sea120.rbn.com for AF_INET...
Connecting to server rx-wes-sea120.rbn.com[66.203.121.135]: 554...
real: Challenge1: bacb4c9ed41a03fcaa564c45f93faacb
real: Stream description size: 1712
number of streams: 1
calling asmrp_match with:
#($Bandwidth < 32041),AverageBandwidth?=16000,Priority=5;#($Bandwidth < 32041),AverageBandwidth?=0,Priority=5,OnDepend?=\"0\", OffDepend?=\"0\";#($Bandwidth >= 32041),AverageBandwidth?=32041,Priority=5;#($Bandwidth >= 32041),AverageBandwidth?=0,Priority=5,OnDepend?=\"2\", OffDepend?=\"2\";
10485800
asmrp rule match: 2 for stream 0
asmrp rule match: 3 for stream 0

hexdump> 2e72 61fd 0005 0000 2e72 6135 0000 0010

0005 0000 0046 0007 0000 022e 0000 0000
0003 aab4 0000 0000 0010 022e 005d 0000
0000 5622 0000 5622 0000 0010 0001 6765
6e72 636f 6f6b 0107 0000 0000 0008 0100
0002 0200 0018

Title: Car Talk Show #0704--Segment 10
Copyright: (C) 2007 Dewey Cheetham and Howe
Author: Car Talk
Streams: 1
============================================================
Note: long delay here
============================================================
Cache size set to 640 KBytes
STREAM: [rtsp] rtsp://rx-wes-sea120.rbn.com/farm/*/cartalk/cartalk/demand/CT0704-10.ra
STREAM: Description: RTSP streaming
STREAM: Author: Benjamin Zores, Roberto Togni
STREAM: Comment: ported from xine
rdt chunk not recognized: got 0x53
rdt chunk not recognized: got 0x4d
Core dumped ;)
vo: x11 uninit called but X11 not inited..

Exiting... (End of file)
[root@linux cartalk]#
...
=================================================================

I have attached security logs from router.

Attachments (2)

mplayer.log (11.0 KB) - added by oliynykko@… 12 years ago.
router security log for mplayer download
flashget.log (5.6 KB) - added by oliynykko@… 12 years ago.
router security log for flashget download

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by oliynykko@…

router security log for mplayer download

comment:1 Changed 12 years ago by oliynykko@…

See "Blocked - Packet invalid in connection"

Changed 12 years ago by oliynykko@…

router security log for flashget download

comment:2 Changed 12 years ago by oliynykko@…

comment:3 Changed 12 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed

check if your router has a label 'sponsored by Real Networks in cooperation with Microsoft'

fix your router or make a new bugzilla with feature request for mplayer to have windows upnp support to open up ports in stupid firewalls.

comment:4 Changed 12 years ago by oliynykko@…

(In reply to comment #3)

check if your router has a label 'sponsored by Real Networks in cooperation
with Microsoft'
fix your router or make a new bugzilla with feature request for mplayer to have
windows upnp support to open up ports in stupid firewalls.

Hi,
It is very kind of you to replay so fast.

I hate windows too :)

One thing is not clear to me:

As you can see 3 log entries are same for mplayer and for flashget.
And those records about openning connections.

After that security log for mplayer has dropped packet message (4).

This is what I found on http://www.jungo.com/openrg/doc/4.5/user_guide/html/html_user_manual/node111.html:

"Packet invalid in connection - a packet has been blocked, being on an invalid connection."

I am afraid that this problem has nothing to do with port openning.

flashget:

1
============================================================================
Jan 30 02:34:53 2007 Inbound Traffic Connection opened TCP 66.203.121.135 554 <--> 66.203.121.135 554 [192.168.200.2 1220 ] CLOSED/SYN_SENT br0 Incoming

2
============================================================================
Jan 30 02:34:53 2007 Outbound Traffic Connection opened TCP 192.168.200.2 1220 <--> 71.172.56.140 1220 [66.203.121.135 554 ] CLOSED/CLOSED ixp0 Outgoing

3
============================================================================
Jan 30 02:34:53 2007 Outbound Traffic Accepted - Default policy TCP 192.168.200.2:1220->66.203.121.135:554 on ixp0

mplayer:

1
===========================================================================
Jan 30 02:29:01 2007 Inbound Traffic Connection opened TCP 66.203.121.135 554 <--> 66.203.121.135 554 [192.168.200.2 32775] CLOSED/SYN_SENT br0 Incoming

2
===========================================================================
Jan 30 02:29:01 2007 Outbound Traffic Connection opened TCP 192.168.200.2 32775<--> 71.172.56.140 32775[66.203.121.135 554 ] CLOSED/CLOSED ixp0 Outgoing

3
===========================================================================
Jan 30 02:29:01 2007 Outbound Traffic Accepted - Default policy TCP 192.168.200.2:32775->66.203.121.135:554 on ixp0

4
===========================================================================
Jan 30 02:29:02 2007 Outbound Traffic Blocked - Packet invalid in connection TCP 71.172.56.140:32775->66.203.121.135:554 on ixp0

comment:5 Changed 12 years ago by reimar

1) Are you crazy? You are running MPlayer as root! Which I guess allows it to try to use your routers IP address as its own (address spoofing). Obviously your router thinks that's a bad idea. Just not running as root will fix that, because then linux itself will think this a bad idea and stop it.
2) What actually is your problem? I get exactly the same output as you and the file is downloaded just fine.

Note: See TracTickets for help on using tickets.