Opened 12 years ago

Closed 12 years ago

#735 closed defect (duplicate)

No output with video non multiple of 16 pixels (mjpeg, planar 422P)

Reported by: mennucc1@… Owned by: beastd
Priority: normal Component: vo
Version: 1.0rc1 Severity: normal
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

GSR reported in Debian BTS that:
When trying to play MJPEG videos in which one or both dimensions are
non multiple of 16, the program detects the size correctly but later
changes size to make it multiple of 16 and playback screen is black
(OSD text is shown fine).

Please read http://bugs.debian.org/406024
for all further details and tests that GSR kindly did and reported.

I can reproduce the bug, e.g. by running
$ mplayer -vo x11 http://briggs.zanqdo.com/nonmanifold.avi
(unfortunately XV does not support 600x600 here)

thanks. a.

Change History (1)

comment:1 Changed 12 years ago by reimar

  • Cc Reimar.Doeffinger@… added
  • Resolution set to duplicate
  • Status changed from new to closed

Do not report conclusion that some random user makes as facts.
It has nothing at all to do with the dimensions, but with the fact that Blender stores an all-black huffman table in the MJPEG files.
So all-black is (at least in some ways) the correct way to decode those files.

* This bug has been marked as a duplicate of bug 642 *

Note: See TracTickets for help on using tickets.