Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#74 closed defect (wontfix)

Configure script broken with coreutils v5.2.1+

Reported by: dorphell@… Owned by: alex@…
Priority: important Component: core
Version: HEAD Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Changes made in coreutils break many parses which make the configure script miss
crucial input such as CPU flags. For example, "head -1" is used in many places,
if you try that command, you'll see it is obsolete. This must be changed to
"head -n 1". Same for "tail -1".

.. and there are many more things in the configure script that missuse head.

Off topic but bugging me.. v4l is being checked for in /dev/video*. It should
also be checked in /dev/v4l/video* too. (udev)

Thank you for your time.

Change History (3)

comment:1 Changed 15 years ago by dominik@…

  • Status changed from new to assigned

It is a known issue. I think it first came up with Gentoo. We've already
discussed it at mplayer-dev-eng and the conclusion was that it won't be fixed
due to compatibility with unices other than Linux. So I think this should be
left as WONTFIX, but I'll leave it for Alex.
As for the other issue you mentioned, either create a new Bugzilla entry or
(better) send a patch to mplayer-dev-eng.

comment:2 Changed 15 years ago by dominik@…

  • Cc dominik@… removed

comment:3 Changed 15 years ago by diego@…

  • Resolution set to wontfix
  • Status changed from assigned to closed

This has been discussed several times. We won't break compatibility with the
rest of the world just to satisfy the newest coreutils version.

Note: See TracTickets for help on using tickets.