Opened 13 years ago

Closed 13 years ago

#742 closed defect (fixed)

Samsungs Digimax i6 PMP Video-Format not supported

Reported by: buzz2@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Samsungs Digimax i6 PMP Format is not supported. According to the manual it is a modified XviD MPEG4 video/MPEG Layer2 audio type; neither a specification nor the source code is support by samsung.

Steps to Reproduce:
Just play sdc-test.avi
mplayer sdc-test.avi

Actual Results
mplayer does not play the file

Expected Results
mplayer should play the file

System informations:
Gentoo 2006.1
Linux thunder 2.6.19-gentoo-r5 #4 PREEMPT Fri Feb 2 21:59:45 CET 2007 i686 Intel(R) Pentium(R) M processor 1.60GHz GenuineIntel? GNU/Linux

libc version:
-rwxr-xr-x 1 root root 1204080 22. Jan 20:13 /lib/libc-2.4.so
lrwxrwxrwx 1 root root 11 22. Jan 20:13 /lib/libc.so.6 -> libc-2.4.so

gcc and ld versions:
Es werden eingebaute Spezifikationen verwendet.
Ziel: i686-pc-linux-gnu
Konfiguriert mit: /var/tmp/portage/gcc-4.1.1-r3/work/gcc-4.1.1/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/4.1.1 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/include/g++-v4 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-libunwind-exceptions --disable-multilib --disable-libmudflap --disable-libssp --disable-libgcj --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-cxa_atexit --enable-clocale=gnu
Thread-Modell: posix
gcc-Version 4.1.1 (Gentoo 4.1.1-r3)

GNU ld version 2.16.1

binutils version:
GNU assembler 2.16.1
Copyright 2005 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License. This program has absolutely no warranty.
This assembler was configured for a target of `i686-pc-linux-gnu'.

Hardware:
processor : 0
vendor_id : GenuineIntel?
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.60GHz
stepping : 6
cpu MHz : 600.000
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe est tm2
bogomips : 1196.49

ATI Mobility Radeon 9700

radeon driver xorg 7.1

sound card: intel 82801db-ich4 (alsa)

log-file:
MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) M processor 1.60GHz (Family: 6, Model: 13, Stepping: 6)
MMX2 supported but disabled
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX SSE SSE2
get_path('codecs.conf') -> '/home/buzz/.mplayer/codecs.conf'
Lese /home/buzz/.mplayer/codecs.conf: Kann '/home/buzz/.mplayer/codecs.conf' nicht öffnen: No such file or directory
Lese /usr/share/mplayer/codecs.conf: Kann '/usr/share/mplayer/codecs.conf' nicht öffnen: No such file or directory
Benutze eingebaute Standardwerte für codecs.conf.
Kommandozeile: '-v' 'sdc-test.avi'
init_freetype
Using MMX Optimized OnScreenDisplay?
Using nanosleep() timing
get_path('input.conf') -> '/home/buzz/.mplayer/input.conf'
Can't open input config file /home/buzz/.mplayer/input.conf: No such file or directory
Parsing input config file /usr/share/mplayer/input.conf
Input config file /usr/share/mplayer/input.conf parsed: 67 binds
get_path('sdc-test.avi.conf') -> '/home/buzz/.mplayer/sdc-test.avi.conf'

Spiele sdc-test.avi.
get_path('sub/') -> '/home/buzz/.mplayer/sub/'
[file] File size is 2864192 bytes
STREAM: [file] sdc-test.avi
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename sdc-test.avi ext: .avi
Trying demuxer 3 based on filename extension
demuxer: continue fuzzy content-based format guessing...
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 73
AVS: avs_check_file - attempting to open file sdc-test.avi
AVS: File is too big, aborting...
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 71728, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=21065 size=951331576
LMLM4 Stream Format not found
sync_mpeg_ps: seems to be MP3 stream...
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 6 p101: 0 p1B6: 8 p12x: 1 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0 MP3: 109, synced: 0
sync_mpeg_ps: seems to be MP3 stream...
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 5 p101: 0 p1B6: 8 p12x: 1 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0 MP3: 109, synced: 0
==> Videostream gefunden: 0
ds_fill_buffer: EOF reached (stream: video)
LAVF_check: no clue about this gibberish!
demux_aac_probe, failed to detect an AAC stream

vo: x11 uninit called but X11 not inited..

Beenden... (Dateiende erreicht)

Change History (3)

comment:2 Changed 13 years ago by ikalvachev@…

File plays fine with:

mplayer -demuxer +avi sdc_test.avi

comment:3 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.