Opened 12 years ago

Last modified 8 years ago

#743 closed defect (fixed)

Make it possible to disable useless modal error dialogs

Reported by: sdiconov@… Owned by: reimar
Priority: normal Component: GUI
Version: HEAD Severity: normal
Keywords: Cc: pacho@…, ib
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

There is a very annoying problem in the GUI with modal error dialogs which make the GUI hard to use.

Problem 1: When I watch HD video i sometimes get uninterraptable stream of stupid error messages like

"Too many video packets in the buffer: (157 in 8405200 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option"

The video would continue to play OK by itself, but hundreds of the error dialogs appear on the screen and interrupt the video making it choppy and impossible to watch.

Problem 2: It is not possible to catch the rapidly jumping and focus grabbing dialogs, so I cannot stop or pause the player. When I kill the GUI it refuses to stop. Instead it seems to freeze until I find yet another useless dialog

"... Was interrapted by signal ..."

It steals time and makes the user frustrated.

Please, send the error messages to console stderr and turn off the GUI notifications.

Change History (7)

comment:1 Changed 12 years ago by compn

you try gmplayer -really-quiet ?
or really-quiet=1 in gui.conf

with svn, rc1 is too old

comment:2 Changed 12 years ago by sdiconov@…

It seems that my Mplayer package is really too old for this.

It says "Warning unknown option really_quiet".

comment:3 Changed 12 years ago by reimar

-really-quiet, not -really_quiet

comment:4 Changed 12 years ago by sdiconov@…

I was using SVN 20xxx + build fixes. Now I have SVN 22173 installed. This option seems to be recognized (gmplayer -really-quiet ? does not give any errors). However, if I write it in the gui.conf, the line disappears without any warnings.

grep quiet /home/slava/.mplayer/gui.conf returns nothing.

comment:5 Changed 12 years ago by reimar

You must put it in .mplayer/config

comment:6 Changed 10 years ago by compn

  • Cc pacho@… added

* Bug 1014 has been marked as a duplicate of this bug. *

comment:7 Changed 8 years ago by ib

  • Resolution set to fixed
  • Status changed from new to closed, ib@wupperonline.de

This should be fixed since svn r31377 even without special quiet options.

Note: See TracTickets for help on using tickets.