Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#745 closed defect (fixed)

Multichannel LADSPA plugins fail to load

Reported by: sdiconov@… Owned by: reimar
Priority: normal Component: ao
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have a Dolby Surround 5.0 receiver (no SP/DIF) connections and a PC with a built-in Analog Devises sound card (stereo out only). The PC has no free slots for any additional sound boards.

This setup is able to play real 3D sound using matrix Dolby surround coding to separate channels sent through a plain stereo jack. However Mplayer has no options to convert AC3/DTS sound into Dolby Surround. All it does is flat stereo. 3D sound tests fail because only two channels are audible.

There is a LADSPA plugin that can turn 5-4 channels into a matrix encoded stereo stream compatible with my Dolby receivers. Mplayer has LADSPA support, but it refuses to load this particular plugin with an error "Only 2-channel plugins are supported".

Please, make it play Dolby Surround too.

Change History (2)

comment:1 Changed 12 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

The perfect example why you are supposed to test SVN before reporting a bug.

separate channels sent through a plain stereo jack. However Mplayer has no
options to convert AC3/DTS sound into Dolby Surround. All it does is flat
stereo. 3D sound tests fail because only two channels are audible.

First, there is no AC3/DTS, there is AC3 and there is DTS. AC3 decoding to surround has always worked (read man page for -channels 6 if you are not aware). Surround decoding for DTS was recently added.
Not sure about matrix encoding though, but I thought there was a filter for that, too.

And now for the main bug report. Support for multichannel LADSPA support was added as well a few days ago. It is untested though.

comment:2 Changed 12 years ago by sdiconov@…

I do not want to distinguish between AC3 and DTS because neither of them is supported by my hardware and Mplayer handles both. The result (6 channels of audio) is identical, so there is no difference for me.

What I am really concerned about is matrix encoding of the demuxed 6 channels into a Dolby Surround stereo stream. It does not work with my mplayer setup and I cannot hear anything from channels 3+ when playing AC3 or DTS audio.

I am delighted to know that it might work with the latest build. I'll write again if it fails though.

Note: See TracTickets for help on using tickets.