Opened 13 years ago

Closed 12 years ago

#750 closed defect (fixed)

Windows Media playlists are not recognized as such

Reported by: svs@… Owned by: r_togni@…
Priority: if idle Component: streaming
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

video/x-ms-wvx (file extension .wvx) is a type of playlist, not a video stream.

Attachments (1)

patch-wvx (1.3 KB) - added by svs@… 13 years ago.
proposed patch

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by svs@…

proposed patch

comment:1 Changed 13 years ago by svs@…

comment:2 Changed 13 years ago by r_togni@…

Is this theonly url that requires it? In the past we had many cases of misconfigured servers sending the wrong mimetype, so I'm quite careful before changing them.
You can force MPlayer with the -playlist option, like you need to do for every other playlist type (asx is one of the few playlist types that is partially autodetected).

comment:3 Changed 12 years ago by svs@…

No, there's many more. http://www.google.com/search?q=inurl%3A.wvx finds quite a few.

comment:4 Changed 12 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

Patch applied.
But this won't fix many of the files that you can fing with the google search you quoted, because the servers are misconfigured and report a wrong mimetype.

Note: See TracTickets for help on using tickets.