Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#763 closed defect (invalid)

Crash with the message "interrupted by signal 6 in module: vo_check_events"

Reported by: patrick_guignot@… Owned by: beastd
Priority: important Component: vo
Version: 1.0pre8 Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I use mplayer on Linux (Ubuntu Edgy)
My laptop is a centrino (1.86 GHz Pentium M with 1GB RAM).

When i launch a particular file mplayer crash (see the terminal session hereunder) :

patrick@laptop:~$ mplayer Madonna_confession_tour.avi
MPlayer 2:0.99+1.0pre8-0ubuntu8 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) M processor 1.86GHz (Family: 6, Model: 13, Stepping: 8)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing Madonna_confession_tour.avi.
AVI file format detected.
AVI: ODML: Building ODML index (2 superindexchunks).
VIDEO: [H264] 1280x720 12bpp 23.976 fps 2992.1 kbps (365.2 kbyte/s)
Clip info:

Software: VirtualDubMod? 1.5.10.1 (Build 2366/Release)

==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 5.1 (3f+2r+lfe) 48000 Hz 448.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
open: No such file or directory
Couldn't open: /dev/mga_vid
open: No such file or directory
Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: Permission denied.
[VO_3DFX] Unable to open /dev/3dfx.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
alsa-init: using device default
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 1280x720 => 1280x720 Planar YV12
aspect: Warning: no suitable new res found!
X11 error: BadAlloc? (insufficient resources for operation)?,?% 0 0

MPlayer interrupted by signal 6 in module: vo_check_events

  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

alsa-uninit: pcm closed
patrick@laptop:~$

Change History (2)

comment:1 Changed 12 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed

please try a newer mplayer version ( like mplayer 1.0rc1 ) from fiesty
http://packages.ubuntu.com/feisty/graphics/mplayer

also you can try mplayer -vo x11 or -vo xv Madonna_confession_tour.avi

marking this invalid because it seems to be a packaged mplayer bug,
not an actual mplayer bug.

also not built from svn with gdb report like mplayer bugreporting howto says:
http://www.mplayerhq.hu/DOCS/HTML/en/bugreports_what.html#bugreports_crash

comment:2 Changed 12 years ago by patrick_guignot@…

Hi

I've tried "mplayer -vo xv Madonna_confession_tour.avi" and it does not work.

Lukily when i've tried "mplayer -vo x11 Madonna_confession_tour.avi" it work !

Thanks for the information and sorry for the bad bug report.

Note: See TracTickets for help on using tickets.