Opened 12 years ago

Closed 8 years ago

#764 closed defect (wontfix)

Support for streaming via Tivo lost in precompiled binaries

Reported by: ciper@… Owned by: reimar
Priority: normal Component: streaming
Version: unspecified Severity: normal
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I'm interested in the feature of mplayer that allows streaming of TY files directly from a Tivo. I had another machine with an older version of Mplayer and this worked properly. It seems that along the way the person compiling the windows binaries on the site forgot to link the library. If you read the document here http://www.mplayerhq.hu/DOCS/man/en/mplayer.1.html you can see this option listed under the synopsis section.

Here is what I am typing and the error I receive.

mplayer tivo://x.x.x.51/list

Playing tivo://x.x.x.51/list.
File not found: 'x.x.x.51/list'
Failed to open tivo://x.x.x.51/list.

I have TivoWebPlus? (a webserver on the tivo) which shows a list of videos currently on the Tivo. Next to each recording is a "View" link which points to an ASX file. This launches Windows Media Player which is successfully able to play the video.

While watching a streamed video in WMP I selected View-Properties to show the fsid address of the file which was tivo://x.x.x.51/3613939

I then tried "mplayer tivo://x.x.x.51/3613939" and got the same error as above.

I have also posted this question to the DealDataBase? forums which offer support for Tivo video extraction. Here is the link to the specific post from me http://www.dealdatabase.com/forum/showthread.php?t=53502

Thanks for your help

Attachments (1)

mplayer.JPG (22.1 KB) - added by ciper@… 12 years ago.
screenshot of error

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by ciper@…

screenshot of error

comment:1 Changed 12 years ago by ciper@…

Here is a screen shot of the error with the full IP address censored.

comment:2 Changed 12 years ago by reimar

Old releases are available at ftp://ftp.mplayerhq.hu/MPlayer/releases/win32 but I am not aware of any including TiVo? support.
If I am wrong tell me and I might consider adding it, though I don't think the number of users this has really justifies it.
There are more precompiled binaries here: http://www.mplayerhq.hu/design7/projects.html but I doubt that any of those include tivo support either...

comment:3 Changed 12 years ago by ciper@…

How many users would I need to find in order to convince the Mplayer team that Tivo support is needed?

comment:4 Changed 12 years ago by reimar

  • Cc Reimar.Doeffinger@… added

You did see http://lists.mplayerhq.hu/pipermail/mplayer-users/2007-February/065658.html
I guess?
According to that the library needed mostly untested on Windows, I don't have a good feeling including "experimental" untested stuff in the official binary.
The reason why I think that this has hardly any users is that AFAIK this only works for the first generation TiVos?, which is a US-only product anyway.
I intend to experiment a bit with it when booting windows next time, but don't hold your breath.

comment:5 Changed 12 years ago by ciper@…

Series 2 Tivos are also able to run the Vserver application. TiVo? service is available in United States, United Kingdom, Canada, and Taiwan. End users have hacked Tivos. to work in Australia, New Zealand, Netherlands, and South Africa.

comment:6 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:7 Changed 8 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

We probably won't provide prebuilt binaries anymore, referring instead to sites like oss.netfarm.it (see related projects).
Might be possible to convince someone to support this...

Note: See TracTickets for help on using tickets.