Opened 12 years ago

Closed 12 years ago

#765 closed defect (worksforme)

mkv subtitles should always be read as UTF-8

Reported by: rpolach@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: 1.0pre8 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

according to Matroska specification
http://www.matroska.org/technical/specs/subtitles/srt.html
http://www.matroska.org/technical/specs/subtitles/ssa.html
SRT and SSA/ASS subtitles inside MKV container
should ALWAYs be treated as UTF-8.

But when my .mplayer/config contain

subcp=cp1250

then this settings overrides UTF-8 default for MKV.

It would be nice to apply config's subcp= setting only to
standalone subtitles (srt files) and not for mkv content,
which should be strictly utf-8.

Maybe some new option like "forcesubcp" should be introduced
for really override MKV subtitle codepage.

Change History (1)

comment:1 Changed 12 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce. pre8 is ancient though.

Note: See TracTickets for help on using tickets.