Opened 12 years ago

Closed 12 years ago

#770 closed defect (duplicate)

build failure on with gcc 4.3 & core2

Reported by: bjrtchsupp@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've been having an issue compiling mplayer using a recent version of gcc 4.3 (compiled locally approx 24-48 hours ago from the svn around 28-Feb-2007). I get this error when it gets to the libavcodec section of the compile. this compile is VERY stripped out (I havent loaded any additional libraries such as xvid, x264 or anything else). This is a vanilla build from the svn (mplayer @ v22428, ffmpeg sections @ 8211). I have tested the compile and it is successful when using march/mtune to be anything reasonable (I tried leaving it out completely as well as prescott and pentium4(m)). I also have tested using -O0 thru -O4 and the only difference is the amount of times it tells me that error (more errors as the # increases).

Below I have included 4 outputs. The first is the one that the configure script generates (-O4 & core2). The second is after I altered it to be -O0. The third is -O4 & prescott. The fourth is just -O4 with no march/mtune. These changes were made only in config.mak in the root directory

I was able to previously build mplayer with no problems when it was at version 22189 when I was using gcc 4.3 built from a snapshot from 04-Dec-2006. Now after this update I am no longer able to compile. I also no longer have the old gcc build to test the current version of mplayer against.

This looks similar (virtually identical, same exact error) to a bug I found on the gcc buglist submitted by one of the ffmpeg developers back in Oct06. You can reference it @ http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29440

Please let me know if you want any additional outputs/tests run. I wasn't sure if this was a mplayer or ffmpeg bug but since it crashed when building mplayer I put it here just in case it was an issue with something else mplayer did in its configure or something related. I apologize if I should have posted this under ffmpeg.

=============================================================================

1) -O4 & core2:
gcc -I../libswscale -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I.. -I.. -I../libavutil -Wdeclaration-after-statement -O4 -march=core2 -mtune=core2 -pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/mingw/include -c -o i386/dsputil_mmx.o i386/dsputil_mmx.c
In file included from i386/../dsputil.h:34,

from i386/dsputil_mmx.c:25:

i386/../avcodec.h:2438: warning: 'ImgReSampleContext?' is deprecated
i386/../avcodec.h:2441: warning: 'ImgReSampleContext?' is deprecated
i386/dsputil_mmx.c: In function 'dsputil_init_mmx':
i386/dsputil_mmx.c:3337: warning: assignment from incompatible pointer type
i386/dsputil_mmx.c:3338: warning: assignment from incompatible pointer type
i386/h264dsp_mmx.c: In function 'h264_h_loop_filter_luma_mmx2':
i386/dsputil_mmx.c:636: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
i386/dsputil_mmx.c:636: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/h264dsp_mmx.c:393: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/h264dsp_mmx.c:393: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
make[1]: * [i386/dsputil_mmx.o] Error 1
make[1]: Leaving directory `/home/Administrator/mplayer/libavcodec'
make:
* [libavcodec/libavcodec.a] Error 2

=============================================================================

2) -O0 & core2

gcc -I../libswscale -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I.. -I.. -I../libavutil -Wdeclaration-after-statement -O0 -march=core2 -mtune=core2 -pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/mingw/include -c -o i386/dsputil_mmx.o i386/dsputil_mmx.c
In file included from i386/../dsputil.h:34,

from i386/dsputil_mmx.c:25:

i386/../avcodec.h:2438: warning: 'ImgReSampleContext?' is deprecated
i386/../avcodec.h:2441: warning: 'ImgReSampleContext?' is deprecated
i386/dsputil_mmx.c: In function 'transpose4x4':
i386/dsputil_mmx.c:636: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
i386/dsputil_mmx.c:636: error: 'asm' operand has impossible constraints
i386/dsputil_mmx.c: In function 'dsputil_init_mmx':
i386/dsputil_mmx.c:3337: warning: assignment from incompatible pointer type
i386/dsputil_mmx.c:3338: warning: assignment from incompatible pointer type
make: * [i386/dsputil_mmx.o] Error 1

=============================================================================

3) -O4 & prescott

gcc -I../libswscale -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I.. -I.. -I../libavutil -Wdeclaration-after-statement -O4 -march=prescott -mtune=prescott -pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/mingw/include -c -o i386/dsputil_mmx.o i386/dsputil_mmx.c
In file included from i386/../dsputil.h:34,

from i386/dsputil_mmx.c:25:

i386/../avcodec.h:2438: warning: 'ImgReSampleContext?' is deprecated
i386/../avcodec.h:2441: warning: 'ImgReSampleContext?' is deprecated
i386/dsputil_mmx.c: In function 'dsputil_init_mmx':
i386/dsputil_mmx.c:3337: warning: assignment from incompatible pointer type
i386/dsputil_mmx.c:3338: warning: assignment from incompatible pointer type

=============================================================================

2) -O4 & no march/mtune

gcc -I../libswscale -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I.. -I.. -I../libavutil -Wdeclaration-after-statement -O4 -pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/mingw/include -c -o i386/dsputil_mmx.o i386/dsputil_mmx.c
In file included from i386/../dsputil.h:34,

from i386/dsputil_mmx.c:25:

i386/../avcodec.h:2438: warning: 'ImgReSampleContext?' is deprecated
i386/../avcodec.h:2441: warning: 'ImgReSampleContext?' is deprecated
i386/dsputil_mmx.c: In function 'dsputil_init_mmx':
i386/dsputil_mmx.c:3337: warning: assignment from incompatible pointer type
i386/dsputil_mmx.c:3338: warning: assignment from incompatible pointer type

=============================================================================

$ gcc --version
gcc.exe (GCC) 4.3.0 20070301 (experimental)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Change History (5)

comment:1 Changed 12 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

This is a bug in the compiler, plus this issue is in the FAQ.

comment:2 Changed 12 years ago by diego@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening to mark as duplicate.

comment:3 Changed 12 years ago by diego@…

  • Resolution set to duplicate
  • Status changed from reopened to closed

* This bug has been marked as a duplicate of bug 604 *

comment:4 Changed 12 years ago by diego@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Reopen to mark as duplicate of another bug.

comment:5 Changed 12 years ago by diego@…

  • Resolution set to duplicate
  • Status changed from reopened to closed

* This bug has been marked as a duplicate of bug 87 *

Note: See TracTickets for help on using tickets.