Opened 13 years ago

Closed 12 years ago

#771 closed defect (duplicate)

wrong time infos when playing .flac files

Reported by: marcel.heinz@… Owned by: r_togni@…
Priority: unimportant Component: ad
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Mplayer shows completely wrong time information when playing .flac files. The "audio" demuxer does calculate an average bitrate value from the FLAC header and the file size, but this information gets overwritten with the value from lavc_context->bit_rate in ad_ffmpeg.c, which only contains the default value of 200kbps for flac files, since the flac decoder does not initialize this value. This might be a bug in ffmpeg as well, since avcodec.h states that the bit_rate field should be set to zero in case the decoder can't get that information from the stream. However, ad_ffmpeg does not check if it is zero either.

Change History (1)

comment:1 Changed 12 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

* This bug has been marked as a duplicate of bug 30 *

Note: See TracTickets for help on using tickets.