Opened 12 years ago

Closed 8 years ago

#780 closed defect (fixed)

DTS Surround Sound not Playing on Stereo - DTS Audio Downmix Regression

Reported by: obsidian@… Owned by: reimar
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

With a recent SVN build, I noticed that videos with DTS surround audio no longer play properly on systems with stereo audio out. You hear some sound, mostly music and effects, but no dialog, no voices.

After some head-banging and googling, I found this traffic on the mplayer list which appears to identify the exact cause of the regression (commit -r 7839), and the person responsible (Reimar):

http://lists.mplayerhq.hu/pipermail/mplayer-users/2007-February/065429.html

Subject: dts decoding broken?
From: <mail at kraymer.de>
Date: Fri, February 9, 2007 5:52 pm
To: <ffmpeg-devel at mplayerhq.hu>

Hello,

I recently noticed that dts decoding doesn't behave like it did before.

Problem: Playing a 5.1 dts stream (either dvd or matroska in my case)
results in only 2 channels being played without downmix. I only have a
setup with two speakers, 5.1 ac3 streams are mixed down and it did the
same with 5.1 dts. Now, I only get 2 out of 6 channels without downmix,
even with -channels 2 and/or -af channels=2. What I get is mainly music
and background sounds, voices are missing.
I did some regression testing and it turned out that a change in ffmpeg,
namely commit -r 7839, introduced that behavior. Using recent mplayer svn
and changing ffmpeg externals to -r 7838 makes the problem go away.. I'm
posting here because I couldn't reproduce the problem with ffplay. That
doesn't mean the problem doesn't exist in ffplay, ffplay simply fails on
the files I'm having the trouble with: a dvd vob (I think ffplay doesn't
cycle through the audio tracks (one ac3, one dts) and doesn't like my
matroska file at all, no sound with either -r7838 or 7839).
Regarding samples, I'm sure the problem is reproducable with every 2.0
setup and a dvd/mkv with dts track. If not, I'll upload parts of my
files..
Please find mplayer output (with ffmpeg -r 7839) attached.

Reimar recently changed dts decoding im ffmpeg in order to allow 6 channels dts
to be decoded as 6 channels. The problem now is that downmix is not working.
It doesn't matter the number of channels you request with -channels, always
6 channels are decoded.
Reimar is this somenthig that should to be fixed in libavcodec or the fix
concerns mplayer?

Ciao
Giacomo

--

This message was dated Feb. 9. There are no answers and I can find no other discussion via searches.

Change History (3)

comment:1 Changed 12 years ago by compn

try -ac ffdca

comment:2 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:3 Changed 8 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Downmixing should finally be implemented again in a different way, please reopen if there are still issues.

Note: See TracTickets for help on using tickets.