Opened 12 years ago

Closed 12 years ago

#787 closed defect (invalid)

Complex multi-screen fullscreen size detection (non uniform xinerama)

Reported by: ludov_dupont@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc1 Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,

I have first to thank the team for making such a great video player.

I guess the problem I have is not a very common one : I got a triple screen layout on two cards (Radeon X800XL with the free drivers).

I use one of the cards to display my dual-headed desktop that runs with a pseudo-xinerama (mergedfb), while I use the other to display medias through xv (with mplayer and mythtv, essentially). Both cards use separate X displays.

Though, if I compile mplayer with the xinerama flag (I use Gentoo), it always detect the fullscreen size of one of my desktop screens, whatever I do (using geometry option do the trick, but is anoying in other ways)... which makes the video far too big and not centered at all...

... to make it display the correct size, the only thing that works (I think I tried each and every options I could find in the manpages) is to compile mplayer without the xinerama flag (which is easy under Gentoo... not so on binary distributions)...

I guess the problem comes with mplayer detecting a xinerama (the mergedfb on the other card) and automatically using the size of the first screen in this xinerama... but on the card where I want fullscreen, there is no xinerama : only an isolated and single X screen...

... so I think mplayer "xineramascreen" option should include a case like "-3" that would be equivalent to "ignore any xinerama, even if mplayer was compiled with the xinerama flag" so that I could make my layout even work with a binary package, without recompiling anything...

This way, wether mplayer or X.org would be responsible for this bug (I am not sure who's fault it is), everything would work ok on all distributions, even with a strange multiple screen with a non uniform xinerama across all the displays (hope I am clear enough)...

Change History (3)

comment:1 Changed 12 years ago by reimar

I am not aware of an X API that would allow to find out that the current default X-Screen is not covered by Xinerama - but there are a lot of X stuff I am not aware of of course.
And -xineramascreen -2 already causes MPlayer to completely ignore xinerama information (-vo xvidix being an exception, -xineramascreen does not work correctly with that at all I guess).

comment:2 Changed 12 years ago by ludov_dupont@…

Well, I must confess I am really ashamed...

... you're right with "-xineramascreen -2" making mplayer ignore any xinerama hint...

Though I am sure I tested this one, I must have been shaking X.org a little bit too much when I did... or maybe it was my neurons that I didn't shake enough...

With this option, everything works rightfully...

I am really confused of having bothered you with what is obviously a misattention whose fault is mine... I was the bug and I guess you can mark it as solved...

Thank you again for this great player and for the precision about "xineramascreen -2".

Otherwise, it may be useful to precise in mplayer manpages that "-xineramascreen -2" meaning fullscreen across the whole virtual display implies it ignores xinerama hints... though it is obvious, it may help anybody as sleepy as I must have been open their eyes quicker :)

comment:3 Changed 12 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

I extended the man page entry a bit.
Since there is a well enough working "workaround" I'm closing it.
The bugreport is still a good thing, there were some more bug reports about xinerama not working right, this might help to figure out any remaining issues.

Note: See TracTickets for help on using tickets.