Opened 12 years ago

Closed 12 years ago

#790 closed defect (worksforme)

libavformat link ordering

Reported by: aaronmgriffin@… Owned by: mans@…
Priority: normal Component: libavformat
Version: unspecified Severity: normal
Keywords: Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Link ordering fails under Win32 (mingw) though it most likely affects
everything. I patched this myself, though it's trivial, I felt like sending
this to you all.

Against libavformat/Makefile Revision: 8628

--- ffmpeg-svn/libavformat/Makefile Wed Apr 4 18:07:56 2007
+++ ffmpeg-new/libavformat/Makefile Wed Apr 4 18:07:49 2007
@@ -147,8 +147,8 @@

OBJS-$(CONFIG_VIDEO_GRAB_V4L_DEMUXER) += grab.o
OBJS-$(CONFIG_VIDEO_GRAB_BKTR_DEMUXER) += grab_bktr.o


-EXTRALIBS := -L$(BUILD_ROOT)/libavutil -lavutil$(BUILDSUF) \

  • -lavcodec$(BUILDSUF) -L$(BUILD_ROOT)/libavcodec $(EXTRALIBS)

+EXTRALIBS := -L$(BUILD_ROOT)/libavcodec -lavcodec$(BUILDSUF) \
+ -L$(BUILD_ROOT)/libavutil -lavutil$(BUILDSUF) $(EXTRALIBS)

CPPOBJS-$(CONFIG_AUDIO_BEOS) += beosaudio.o

Change History (2)

comment:1 Changed 12 years ago by diego@…

  • Cc diego@… added

Is this still a problem?

comment:2 Changed 12 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

not enough info. mingw? cygwin? what command?

works for me.

Note: See TracTickets for help on using tickets.