Opened 12 years ago

Closed 12 years ago

#792 closed defect (worksforme)

compilation broken with amr.c

Reported by: mplayer-bugs@… Owned by: mans@…
Priority: important Component: libavcodec
Version: unspecified Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

After the recent change in amr-code handling compiling with the instruktions found at the top of libavcodec/amr.c doesn't work anymore.
The instructions want the code in amr_float and amrwb_float, amr.c uses amrnb and amrwb in its include statements.

Additionally, there's a definition missing:

In amr_wb_decode_frame() block_size[] is used but not declared, using the definition from amr_nb_decode_frame() fixes compilation, not sure, if the values are correct for wb, though.

What's more, when trying to build mplayer with a recent version of ffmpeg and amr-code, linking is broken because the amr-code isn't compiled at all and isn't included in the final linking step.

I'm mentioning this here, because IMHO the amr-code should be compiled by the ffmpeg build system and included in libavcodec rather then standalone.

Attachments (2)

patch.compile2 (980 bytes) - added by mplayer-bugs@… 12 years ago.
compilation fix for amr.c
patch.2.compile2 (406 bytes) - added by mplayer-bugs@… 12 years ago.
compilation fix for amr.c v2

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by mplayer-bugs@…

compilation fix for amr.c

comment:1 Changed 12 years ago by mplayer-bugs@…

comment:2 Changed 12 years ago by mplayer-bugs@…

As the mplayer-team changed the build process to use external amr, too, here's a new patch that fixes just the missing definition in amr.c.

For the records, the amr-libs can be build with

make -f makefile.gcc
rm decoder.o encoder.o
ar cr libamrnb.a *.o
ranlib libamrnb.a

(the same goes for amrwb, just replate amrnb with amrwb)

Changed 12 years ago by mplayer-bugs@…

compilation fix for amr.c v2

comment:3 Changed 12 years ago by mplayer-bugs@…

  • attachments.isobsolete changed from 0 to 1

comment:4 Changed 12 years ago by mplayer-bugs@…

  • Resolution set to worksforme
  • Status changed from new to closed

With amrnb-6.1.0.4 and amrwb-7.0.0.1 there're no errors in compilation, the patch is no longer needed.

Note: See TracTickets for help on using tickets.