Opened 12 years ago

Closed 12 years ago

#801 closed defect (wontfix)

mplayer -pid

Reported by: dilyan.palauzov@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I would like to have a -pid option on the mplayer's command line, that writed the pid of the mplayer process in a file.

I use mplayer to listen radio. I do not sit always a front of my computer, so I would like to record the emission using a cron job, However starting mplayer URL does not always work when the servers are busy I have to retype it several times. To save all the work, I would like to write a cron-script that starts recording at specific time and stops when my favourite emissions are ready. To stop the mplayer I need its pid, and I needed when I start the recording - to see if mplayer is running with the current stream, or to retry if it isn't. Stopping mplayer with 'killall mplayer' is not a good idea, since I might listen to something else, I even record two things simultaneously.

To solve all this troubles, I would appreciate if mplayer can optionally save its process ID (pid) in a user defined file.

Change History (1)

comment:1 Changed 12 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

Just use the proper shell features, one out of $!, jobs -p or $$ to get the PID and store it somewhere.

Note: See TracTickets for help on using tickets.