Opened 12 years ago

Closed 12 years ago

#810 closed defect (duplicate)

Playback problems with specific set of video files: One Piece Kaizoku Fansubs

Reported by: awilliamson@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've come across a set of files that seem to be problematic in many players: all episodes of the Japanese TV series One Piece subtitled by the Kaizoku Fansubs group since they shifted to widescreen (episode 208, I believe). The files are H.264 video with AAC audio. mplayer will start to play them correctly - with a warning that the FPS value is wrong - but will stop or cycle back to the start of the file after 11 minutes or so. When skipping through the file, the progress bar is obviously wrong (it says you're at the end of the file when the opening credits are still playing).

As I said, these files appear to be problematic for all players: xine crashing with a floating point exception, and gstreamer wouldn't play the video at all until I filed a bug which caused them to fix the problem: http://bugzilla.gnome.org/show_bug.cgi?id=426972 . I guess looking at what the gstreamer guys did may help, I don't know.

I have reproduced this on two different machines, with current SVN mplayer.

You can download the videos in question at http://xdcc.discoveryhosting.nl/tracker/ . Any episode since 208 should display the problem.

I can provide mplayer -v output if necessary, but it's quite long so I won't unless asked.

Thanks!

I wasn't sure which component to file this on, so I guessed at core.

Change History (3)

comment:1 Changed 12 years ago by compn

k-f files have caused problems before... see bug #403

can you try mplayer -demuxer lavf file
maybe it helps.

comment:2 Changed 12 years ago by awilliamson@…

You're right: with that, it works perfectly.

Not a fix for me though, unless I can always use that parameter for .mp4 files - I run mplayer through freevo so I can't pick arbitrary parameters for every file. the finest grained control I have is to use a particular set of parameters for all .mp4 files. is the default demuxer going to get fixed?

comment:3 Changed 12 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

the default demuxer is unmaintained
mplayer is moving towards -demuxer lavf sooner or later
this is a duplicate bug, so closing it now.

* This bug has been marked as a duplicate of bug 403 *

Note: See TracTickets for help on using tickets.