Opened 12 years ago

Closed 12 years ago

#827 closed defect (fixed)

random speed-up of video

Reported by: namlessone@… Owned by: beastd
Priority: normal Component: vo
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Sometimes when watching a movie the video is played very fast for a few seconds and then it just waits for the audio to catch up and plays like normal. This happens randomly, never in the same place for a given file.
I'm using gentoo and i started experiencing this bug like 3-4 months ago but kept upgrading mplayer to see if its fixed. Up to this point i have not been able to determine the exact cause of this bug, no unusual CPU/IO activity while it happens, no warnings from mplayer.
Right now i'm using mplayer-1.0.20070427.
I noticed that this bug does not happen on Solaris.
I can provide any additional details as required, right now i'm using
a 2.6.19 kernel with a 2.5 glibc and gcc 4.1.2.

Change History (7)

comment:1 Changed 12 years ago by compn

any chance you could compile mplayer yourself and test it?

or possibly test as root ?

also .. -autosync 30 and/ or -mc 0
also try changing your audio output (e.g. try oss or alsa or esound )

comment:2 Changed 12 years ago by namlessone@…

I hope you are aware that gentoo is a source based distro. Anyway, i've compiled a copy of mplayer myself, also tried all available audio(alsa, oss, esnd) and video outputs(xv, x11, gl, gl2, fbdev) but the problem is still there.
I already had the autosync option, also tried using a cache, nothing works.
Also it seems that its not influenced by load.

comment:3 Changed 12 years ago by reimar

Is this for some files or for all? Does -correct-pts or specifying a -fps make a difference? How about -srate 44100 or -srate 48000? What does the status bar show during the progress, esp. how does the A-V value change over time?

comment:4 Changed 12 years ago by compn

(In reply to comment #2)

I hope you are aware that gentoo is a source based distro.

yes and gentoo USE flags are a common cause of problems for mplayer users.

mplayer -v yourfile , copy paste all output here would be nice...

comment:5 Changed 12 years ago by namlessone@…

Right now i've experienced a reiserfs crash and i'm in the process of backing up what data i can recover. I'll report back here as soon as i have replaced the disk and restored my system.

PS: there is no point in the -v option, i've tried, nothing out of the ordinary happens and since this bug is very random i usually have to watch 30 min of video to experience it once.

PPS: I have used mplayer long before gentoo and compiled it by hand on many computers. With the USE flags since they only pass --enable or --disable to ./configure i've enabled what i normally enable when compiling by hand.

comment:6 Changed 12 years ago by beastd

(In reply to comment #5)

Right now i've experienced a reiserfs crash and i'm in the process of backing
up what data i can recover. I'll report back here as soon as i have replaced
the disk and restored my system.

Is the problem still there?

PS: there is no point in the -v option, i've tried, nothing out of the ordinary
happens and since this bug is very random i usually have to watch 30 min of
video to experience it once.

Still -v output would be nice, you never know...


PPS: I have used mplayer long before gentoo and compiled it by hand on many
computers. With the USE flags since they only pass --enable or --disable to
./configure i've enabled what i normally enable when compiling by hand.

But there is a probability that gentoo distributes patched sources, isn't it?

comment:7 Changed 12 years ago by namlessone@…

  • Resolution set to fixed
  • Status changed from new to closed

(In reply to comment #6)
yes patches are distributed.
but somewhere betwen restoring and upgrading my system the bug is gone.
i thing that it was some kind of kernel bug because after upgrading that a lot of things started behaving. PS: you could make this page a little more mobile friendly because as it is its very hard to browse the bugs.

Note: See TracTickets for help on using tickets.