Opened 12 years ago

Closed 12 years ago

#837 closed defect (duplicate)

mplayer cannot play (certain types of) multi-clip wmv with asf header

Reported by: amir@… Owned by: r_togni@…
Priority: important Component: demuxer
Version: 1.0rc1 Severity: major
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I try to play the following stream with mplayer :
mms://217.218.165.252/tv1/tv1_13860311_030.wmv

Here is what I get :
==========================================================================
$ mplayer mms://217.218.165.252/tv1/tv1_13860311_030.wmv
MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.20GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing mms://217.218.165.252/tv1/tv1_13860311_030.wmv.
STREAM_ASF, URL: mms://217.218.165.252/tv1/tv1_13860311_030.wmv
Resolving 217.218.165.252 for AF_INET6...
Couldn't resolve name for AF_INET6: 217.218.165.252
Connecting to server 217.218.165.252[217.218.165.252]: 1755...
Connected
file object, packet length = 1130 (1130)
unknown object
stream object, stream ID: 1
stream object, stream ID: 2
unknown object
unknown object
data object
mmst packet_length = 1130
Cache size set to 64 KBytes
Cache fill: 12.50% (8192 bytes)
ASF file format detected.
Everything done. Thank you for downloading a media file containing proprietary and patented technology.
Clip info:

name:
author:
copyright:
comments:

==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 8000 Hz, 1 ch, s16le, 0.1 kbit/0.10% (ratio: 16->16000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 7.0 (07.0) of 9.0 (09.0) 0.6% 0%

Exiting... (End of file)
==========================================================================

This stream, is a multi-part wmv. When I play it in WMP, first there is a 7
second clip with a logo and silence and then the player is redirected to the
main clip.

In mplayer the initial 7 second clip is understood partially ( no video )
and then it quits without being forwarded to the main clip.

I tried it with the precompiled version : MPlayer 1.0rc1-4.1.1
and then I downloaded and built from the svn and I got the same result.

regards
Amir

Change History (1)

comment:1 Changed 12 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

mms playlist bug still not fixed :(

* This bug has been marked as a duplicate of bug 424 *

Note: See TracTickets for help on using tickets.