Opened 12 years ago

Closed 12 years ago

#850 closed defect (fixed)

arguments in rtsp:// urls are ignored, if they are quoted.

Reported by: mplayer@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

If the "start" argument in an rtsp:// URL is quoted, then mplayer ignores it.
Websites such as the BBC's listen-again stream [3] give URLs such as [1]. However, the start attribute is ignored by mplayer, and the stream starts at position zero. If I manually strip the quotes (eg [2]), it does what I expect, starting 30 minutes into the stream (i.e. at the start of the radio programme I actually want to hear).

[1] rtsp://rmv8.bbc.net.uk/bbc7/2300_tue.ra?start="30:00" #fails
[2] rtsp://rmv8.bbc.net.uk/bbc7/2300_tue.ra?start=30:00 #works
[3] http://www.bbc.co.uk/bbc7/listenagain/monday/ #example

Change History (3)

comment:1 Changed 12 years ago by r_togni@…

  • Status changed from new to assigned

Can you tell some more informations about your setup? I can't reproduce it both with 1.0rc1 and current SVN.

comment:2 Changed 12 years ago by mplayer@…

This is the mplayer version - it's the standard one as shipped with Ubuntu 7.04.

MPlayer 2:1.0~rc1-0ubuntu9.1 (C) 2000-2006 MPlayer Team
CPU: Genuine Intel(R) CPU T2600 @ 2.16GHz (Family: 6, Model: 14, Stepping: 8)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

A thought: are you typing these in directly at the shell? If so, bash will helpfully strip the quotes for you.

Try the difference between:

$ LOCATION='rtsp://rmv8.bbc.net.uk/bbc7/2300_tue.ra?start="30:00"'
$ mplayer -cache 100 $LOCATION
(wrong)

$ LOCATION='rtsp://rmv8.bbc.net.uk/bbc7/2300_tue.ra?start=30:00'
$ mplayer -cache 100 $LOCATION

comment:3 Changed 12 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in svn

Note: See TracTickets for help on using tickets.