Opened 12 years ago

Last modified 9 years ago

#856 closed defect (worksforme)

dvdnav dont' display dvd menu,dead after 1 second

Reported by: metrobotte@… Owned by: reimar
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I use latest svn mplayer,latest libdvdnav
from svn,of course mplayer is compiled
with dvdnav support.
When i launch a dvd with
mplayer dvdnav://

mplayer dvdnav://0
MPlayer dev-SVN-r23698-4.1.2 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (Family: 15, Model: 75, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
112 audio & 235 video codecs
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not open config files /home/giuseppe/.lircrc and /etc/lircrc
mplayer: No such file or directory
Failed to read LIRC config file ~/.lircrc.
Menu inited: /home/giuseppe/.mplayer/menu.conf

Playing dvdnav://0.
libdvdnav: Using dvdnav version 0.2.1cvs from http://dvd.sf.net
libdvdnav: DVD Title: MILANO_SCN
libdvdnav: DVD Serial Number: 33226800
libdvdnav: DVD Title (Alternative):
libdvdnav: Unable to find map file '/home/giuseppe/.dvdnav/MILANO_SCN.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fd0000. Regions: 2
dvdnav_stream, you didn't specify a track number (as in dvdnav://1), playing whole disc
libdvdnav: Language 'en' not found, using 'it' instead
libdvdnav: Menu Languages available: it
libdvdnav: Language 'en' not found, using 'it' instead
libdvdnav: Menu Languages available: it
libdvdnav: Language 'en' not found, using 'it' instead
libdvdnav: Menu Languages available: it
INIT ERROR: -1081587568, couldn't get init pos New position not yet determined.
Remember to disable MPlayer's cache when playing dvdnav:// streams (adding -nocache to your command line)
DVDNAV, switched to title: 2
libdvdnav: Language 'en' not found, using 'it' instead
libdvdnav: Menu Languages available: it
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 3) 25.000 fps 8000.0 kbps (1000.0 kbyte/s)
Opening video filter: [screenshot]
Opening video filter: [eq2]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
SwScaler?: reducing / aligning filtersize 5 -> 4
SwScaler?: reducing / aligning filtersize 5 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 1
SwScaler?: reducing / aligning filtersize 5 -> 4
[swscaler @ 0x890e418]SwScaler?: BICUBIC scaler, from yuv420p to bgr24 using MMX2
[swscaler @ 0x890e418]SwScaler?: using 4-tap MMX scaler for horizontal luminance scaling
[swscaler @ 0x890e418]SwScaler?: using 4-tap MMX scaler for horizontal chrominance scaling
[swscaler @ 0x890e418]SwScaler?: using n-tap MMX scaler for vertical scaling (BGR)
[swscaler @ 0x890e418]SwScaler?: using MMX2 YV12->BGR24 Converter
[swscaler @ 0x890e418]SwScaler?: 720x576 -> 1024x576
VO: [xv] 720x576 => 1024x576 Planar YV12
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 1024x576 Planar YV12
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 1024x576 Planar YV12
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 1024x576 Planar YV12
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 1024x576 Planar YV12
A: 0.6 V: 0.3 A-V: 0.264 ct: 0.028 8/ 8 ??% ??% ??,?% 0 0
Too many audio packets in the buffer: (4096 in 8255808 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Too many audio packets in the buffer: (4096 in 8255808 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
A: 0.6 V: 0.3 A-V: 0.278 ct: 0.032 8/ 8 ??% ??% ??,?% 0 0

Exiting... (End of file)

This is what happen...
menu dies after 1 second!!
:(

Change History (2)

comment:1 Changed 9 years ago by compn

  • Owner changed from beastd to reimar

comment:2 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

try with svn.

Note: See TracTickets for help on using tickets.