Opened 12 years ago

Closed 10 years ago

#914 closed defect (fixed)

mplayer doesn't play a vorbis avi

Reported by: peter@… Owned by: r_togni@…
Priority: unimportant Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer doesn't play this sample which has been up since 2001:
http://samples.mplayerhq.hu/A-codecs/vorbis-avi/Coyote.Ugly.Sample.Ogg.Vorbis.avi

vlc and xine play only the video, gstreamer plays video and audio.

I marked this low priority since vorbis in avi sucks. I marked it as a demuxer bug since that would be my guess.

mplayer Coyote.Ugly.Sample.Ogg.Vorbis.avi
MPlayer dev-SVN-r24760-4.1.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (Family: 6, Model: 15, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing Coyote.Ugly.Sample.Ogg.Vorbis.avi.
Cache fill: 0.00% (0 bytes)
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO: [DIV3] 640x480 24bpp 25.000 fps 1867.0 kbps (227.9 kbyte/s)
[gl] using extended formats. Use -vo gl:nomanyfmts if playback fails.
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: BGR 24-bit)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: BGR 24-bit)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: BGR 24-bit)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: BGR 24-bit)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: BGR 24-bit)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: BGR 24-bit)
VDec: using BGR 24-bit as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [gl] 640x480 => 640x480 BGR 24-bit [flip]
Selected video codec: [rawbgr24flip] vfm: raw (RAW BGR24)
==========================================================================
==========================================================================
Forced audio codec: mad
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[vorbis @ 0xdf3f60]Extradata corrupt.
Could not open codec.
ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [libvorbis] Ogg/Vorbis? audio decoder
ad_vorbis, extradata seems to be absent! exit
ADecoder init failed :(
ADecoder init failed :(
Cannot find codec for audio format 0x73627276.
Read DOCS/HTML/en/codecs.html!
Audio: no sound
Starting playback...
Frame too small! (12686<921600) Wrong format?
Frame too small! (10970<921600) Wrong format?
Frame too small! (9314<921600) Wrong format?
Frame too small! (9146<921600) Wrong format?
Frame too small! (8077<921600) Wrong format?
Frame too small! (8117<921600) Wrong format?
Frame too small! (7013<921600) Wrong format?
Frame too small! (6900<921600) Wrong format?
Frame too small! (6688<921600) Wrong format?
Frame too small! (6932<921600) Wrong format?
Frame too small! (7077<921600) Wrong format?
Frame too small! (7758<921600) Wrong format?
Frame too small! (8691<921600) Wrong format?
Frame too small! (5897<921600) Wrong format?
Frame too small! (5695<921600) Wrong format?
Frame too small! (414<921600) Wrong format?
Frame too small! (5567<921600) Wrong format?
Frame too small! (6030<921600) Wrong format?
Frame too small! (6202<921600) Wrong format?
Frame too small! (5713<921600) Wrong format?
Frame too small! (5824<921600) Wrong format?
Frame too small! (5416<921600) Wrong format?
Frame too small! (5607<921600) Wrong format?
Frame too small! (6083<921600) Wrong format?
Frame too small! (6297<921600) Wrong format?
Frame too small! (6666<921600) Wrong format?
Frame too small! (6865<921600) Wrong format?
Frame too small! (8976<921600) Wrong format?
Frame too small! (6549<921600) Wrong format?
Frame too small! (6623<921600) Wrong format?
Frame too small! (436<921600) Wrong format?
Frame too small! (7086<921600) Wrong format?
Frame too small! (7753<921600) Wrong format?
Frame too small! (7774<921600) Wrong format?
Frame too small! (7280<921600) Wrong format?
Frame too small! (7083<921600) Wrong format?
Frame too small! (6865<921600) Wrong format?
Frame too small! (7331<921600) Wrong format?
Frame too small! (7436<921600) Wrong format?
Frame too small! (7223<921600) Wrong format?
Frame too small! (6802<921600) Wrong format?
Frame too small! (6739<921600) Wrong format?
Frame too small! (8347<921600) Wrong format?
Frame too small! (6165<921600) Wrong format?
Frame too small! (5819<921600) Wrong format?
Frame too small! (507<921600) Wrong format?
Frame too small! (6137<921600) Wrong format?
Frame too small! (6184<921600) Wrong format?
Frame too small! (6298<921600) Wrong format?
Frame too small! (5991<921600) Wrong format?
Frame too small! (6215<921600) Wrong format?
Frame too small! (48489<921600) Wrong format?
Frame too small! (4879<921600) Wrong format?
Frame too small! (9513<921600) Wrong format?
Frame too small! (7080<921600) Wrong format?
Frame too small! (18208<921600) Wrong format?
V: 2.2 56/ 56 0% 0% 0.0% 0 0 43%
--(I pressed up-arrow here)
MPlayer interrupted by signal 11 in module: seek

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Change History (5)

comment:1 Changed 12 years ago by peter@…

this is a lot like bug 587, but in my case the video doesn't play either.

comment:2 Changed 12 years ago by compn

there is no guarantee the mplayer samples database has working files.
did you see if this file plays in any other player (could be broken file).

video works for me with this sample

Forced audio codec: +vorbis
Opening audio decoder: [libvorbis] Ogg/Vorbis? audio decoder
ad_vorbis: Vorbis track does not contain valid headers.

Forced audio codec: +ffvorbis
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[vorbis @ 0x609264]Extradata corrupt.

comment:3 Changed 12 years ago by peter@…

(In reply to comment #2)

there is no guarantee the mplayer samples database has working files.
did you see if this file plays in any other player (could be broken file).

Yes. vlc and xine play only the video, gstreamer plays video and audio.

comment:4 Changed 11 years ago by selmi@…

i tried to make avi file with vorbis audio with recent svn version (from 2.11.2008). i noticed that in created file seeking doesn't work at all, video moves forward but sound is still played from the beginning, so its unusable

comment:5 Changed 10 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

works in svn

Note: See TracTickets for help on using tickets.