Opened 12 years ago

Closed 10 years ago

#918 closed defect (invalid)

1.0rc2 fails to make/compile (whilst 1.0rc1 previously did)

Reported by: ajb.stxsl@… Owned by: reimar
Priority: very important Component: core
Version: unspecified Severity: critical
Keywords: Cc: ajb.stxsl@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

(1) Downloaded source code.
(2) cd MPlayer-1.0rc2
(3) configure > LOG.0 2> LOG.err.0
(4) view configure.log LO*0 # all looks o.k.
(5) make > LOG.1 2> LOG.err.1
(6) make install > LOG.2 2> LOG.err.2
(7) view LO*.[12] # errors noted relating to stream_dvd.o

The log files configure.log, LO*.[0-2] are available.

Attachments (2)

log-files.tar.gz (22.4 KB) - added by ajb.stxsl@… 12 years ago.
The log files described in the original report.
in.h (12.3 KB) - added by ajb.stxsl@… 12 years ago.
The file /usr/include/netinet/in.h

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by ajb.stxsl@…

The log files described in the original report.

comment:1 Changed 12 years ago by ajb.stxsl@…

comment:2 Changed 12 years ago by reimar

What systems is this exactly?
My /usr/include/netinet/in.h does not use u32 and such crap, thus I strongly suspect that at least that file is broken on your system.

comment:3 Changed 12 years ago by ajb.stxsl@…

  • Cc stxsl_ajb@… added

System is based on Red Hat Linux 9.

# uname -a
Linux stxsl 2.4.20-8-PIII #1 Mon Sep 17 09:38:31 BST 2007 i686 i686 i386 GNU/Linux

Would you like to see the file in.h ?

Changed 12 years ago by ajb.stxsl@…

The file /usr/include/netinet/in.h

comment:4 Changed 12 years ago by ajb.stxsl@…

Here's the include file. If you have the time I would appreciate your comments.

comment:5 Changed 12 years ago by ajb.stxsl@…

Upgraded OS (to CentOS 5.0).

# uname -a
Linux stxsl 2.6.18-8.el5 #1 SMP Thu Mar 15 19:57:35 EDT 2007 i686 i686 i386 GNU/Linux

Package now configures & makes cleanly with no errors.

I suggest that this bug is flagged as due to defective RHL9 and just archived.

Thanks for your time & for looking.

comment:6 Changed 10 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed

bug > closed

Note: See TracTickets for help on using tickets.