Opened 12 years ago

Closed 10 years ago

#919 closed defect (worksforme)

Mplayer Cygwin build crashes on Vista x64 when using dsound

Reported by: qonml@… Owned by: reimar
Priority: normal Component: ao
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Im running Vista x64 on an Intel quadcore q6600.
I build Mplayer rc2 using cygwin (after patching that llrint thing).
When I use dsound for audio output I get the message
"Mplayer - Movie Player has stopped working"
Though when I click Close the program it runs then without any problem.
I do not know why windows does not kill the process when pressing Close Program though as it does for other programs

This happens with any input file (tried different video files or just plain pcm wave files)
When using win32 audio output everything works fine.
I tried the binary on other os and did not get any error there (XP64 / 2k3 64 / XP32)
Though I tried several different computers running Vista64 and it always crashed
Unfortunately I do not have Vista32 to test
I added some debug output to ao_dsound.c to see where exactly mplayer crashes.
I recognized the crash did not occur on the same position in ao_dsound all the time. So I do not even now if ao_dsound.c produces the crash.
What I further recognized is that when starting MPlayer under heavy load so that i takes about 5 sec to start it does not crash sometimes. So I though maybe some race condition might be the problem and restricted Mplayer on one CPU. Unfortunately this also did not help.
It also does not crash when running under Visual Studio Debugger. Though it did crash after enabling all exceptions in the debugger. The debugger then gives me a First Chance Exception.
I tried several Mingw32 build (even did a mingw build using the same source as for the cygwin build) and they all were ok.
So the problem appears exactly when

Using Windows Vista 64 (32 may also be affected)
Havind compiled Mplayer under cygwin environment
Using dsound audio output
Not Running Visual Studio Debugger

Change History (1)

comment:1 Changed 10 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

mplayer should be working on vista
reopen if you hit this bug again.

Note: See TracTickets for help on using tickets.