Opened 11 years ago

Last modified 11 years ago

#936 reopened defect

audio playback speed problems for flv format

Reported by: abenea@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I concatenated 2 flv files (let's call them file1.flv and file2.flv - both played back correctly in mplayer) and got a resulting flv file (let's call it result.flv) that plays well with youtube's flash player. But MPlayer gets the sound speed wrong for this file.

To be more specific: the first part of result.flv plays ok (the part from file1.flv) but the second part plays the audio stream 2x slower (i was able to verify this playing at 2x speed the second part and got correct audio).

I suspect the 2 files have different sampling rates for audio, and mplayer picks the sampling rate of the first flv audio tag for the whole duration of the file.

The build i used was Sherpya-SVN-r24930-4.2.1.

Change History (10)

comment:1 Changed 11 years ago by abenea@…

A test case for reproducing this bug can be found at http://youtube.com/watch?v=qgAbnEySPr8 (you can use http://keepvid.com/ to get the flv file).

comment:2 Changed 11 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed

bug invalid, cat file1 file2 > file3 is not a valid file.

comment:3 Changed 11 years ago by abenea@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I did NOT concatenate the files with cat. I used a program that parses the .flv file format. Just test the link above, and you'll be able to reproduce the bug (and no, the resulting file is NOT invalid, since it plays fine on youtube).

comment:4 Changed 11 years ago by compn

oh , my bad

what program did you use ?

comment:5 Changed 11 years ago by abenea@…

I used a program written by a coworker :P (he used the specs from http://osflash.org/flv)

comment:6 Changed 11 years ago by compn

so an flv file with two different audio samples is within the flv specs?

aside from the fact that it plays with stupid flash plugin....

comment:7 Changed 11 years ago by compn

btw check if it plays with ffplay (if you can find a win32 binary)

mplayer uses the flv demuxer from ffmpeg, so it might be their bug...

might submit a bugreport to ffmpeg bug tracker http://roundup.mplayerhq.hu

comment:8 Changed 11 years ago by abenea@…

(In reply to comment #6)

so an flv file with two different audio samples is within the flv specs?

aside from the fact that it plays with stupid flash plugin....

Yes. I've just read the official specs and there's nothing that says the audio/video tags must have the same properties (you can even have different video resolutions).

ffplay behaves the same as mplayer on that file.

comment:9 Changed 11 years ago by abenea@…

I also tried with different video codecs suported by the flv format in the same file. It seems that mplayer uses the first video tag's codec for all the flv tags... obviously this leads to decoding errors.

comment:10 Changed 11 years ago by compn

thanks for submitting it to ffmpeg tracker, it will get more attention there :)

Note: See TracTickets for help on using tickets.