Opened 12 years ago

Closed 12 years ago

#940 closed defect (wontfix)

configure does not detect fontconfig correctly on OSX 10.5

Reported by: stranche@… Owned by: diego@…
Priority: normal Component: build system
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

with SVN
OSX 10.5 Xcode 3.0

when issuing ./configure you get

Checking for freetype >= 2.0.9 ... no
Checking for fontconfig ... no (freetype support needed)
Checking for SSA/ASS support ... no (FreeType? support needed)

when issuing ./configure --with-freetype-config=/usr/X11R6/bin/freetype-config you get the same

Checking for freetype >= 2.0.9 ... no
Checking for fontconfig ... no (freetype support needed)
Checking for SSA/ASS support ... no (FreeType? support needed)

Other informations :

# /usr/X11R6/bin/freetype-config --version
9.16.3
# /usr/X11R6/bin/freetype-config --ftversion
2.3.5
# /usr/X11R6/bin/freetype-config --libs
-L/usr/X11/lib -lfreetype -lz -Wl,-framework,CoreServices?,-framework,ApplicationServices?
# /usr/X11R6/bin/freetype-config --libtool
/usr/X11/lib/libfreetype.la
# /usr/X11R6/bin/freetype-config --cflags
-I/usr/X11/include/freetype2 -I/usr/X11/include

Change History (6)

comment:1 Changed 12 years ago by diego@…

  • Status changed from new to assigned

Look into configure.log and check why it fails, paste the relevant part here.

comment:2 Changed 12 years ago by stranche@…

(In reply to comment #1)
here is the ./configure part

============ Checking for freetype >= 2.0.9 ============

#include <stdio.h>
#include <ft2build.h>
#include FT_FREETYPE_H

#if ((FREETYPE_MAJOR < 2)
((FREETYPE_MINOR == 0) && (FREETYPE_PATCH < 9)))

#error "Need FreeType? 2.0.9 or newer"
#endif
int main()
{

FT_Library library;
FT_Int major=-1,minor=-1,patch=-1;
int err=FT_Init_FreeType(&library);
if(err){

printf("Couldn't initialize freetype2 lib, err code: %d\n",err);
exit(err);

}
FT_Library_Version(library,&major,&minor,&patch); in v2.1.0+ only :(((
printf("freetype2 header version: %d.%d.%d library version: %d.%d.%d\n",

FREETYPE_MAJOR,FREETYPE_MINOR,FREETYPE_PATCH,
(int)major,(int)minor,(int)patch );

if(major!=FREETYPE_MAJOR
minor!=FREETYPE_MINOR){

printf("Library and header version mismatch! Fix it in your distribution!\n");
exit(1);

}
return 0;

}

cc -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4 -march=pentium-m -mtune=pentium-m -pipe -ffast-math -fomit-frame-pointer -I/usr/local/include -I/usr/X11/include -L/usr/local/lib -liconv -lncurses -framework Carbon -framework QuickTime? -framework CoreAudio? -framework AudioUnit? -framework AudioToolbox? -framework Cocoa -framework QuartzCore? -framework OpenGL -framework IOKit -framework IOKit -framework OpenAL -o /var/folders/vY/vYgRq8PFH7WdkSKVPkq4H++++TI/-Tmp-mplayer-conf-32687-65083 /var/folders/vY/vYgRq8PFH7WdkSKVPkq4H++++TI/-Tmp-mplayer-conf-19439-65083.c -I/usr/X11/include/freetype2 -I/usr/X11/include -L/usr/X11/lib -lfreetype -lz -Wl,-framework,CoreServices?,-framework,ApplicationServices?
ld: cycle in dylib re-exports with /usr/X11/lib/libGL.dylib
collect2: ld returned 1 exit status

Result is: no
##########################################

here is the result wth ./configure --with-freetype-config=/usr/X11R6/bin/freetype-config part

============ Checking for freetype >= 2.0.9 ============

#include <stdio.h>
#include <ft2build.h>
#include FT_FREETYPE_H

#if ((FREETYPE_MAJOR < 2)
((FREETYPE_MINOR == 0) && (FREETYPE_PATCH < 9)))

#error "Need FreeType? 2.0.9 or newer"
#endif
int main()
{

FT_Library library;
FT_Int major=-1,minor=-1,patch=-1;
int err=FT_Init_FreeType(&library);
if(err){

printf("Couldn't initialize freetype2 lib, err code: %d\n",err);
exit(err);

}
FT_Library_Version(library,&major,&minor,&patch); in v2.1.0+ only :(((
printf("freetype2 header version: %d.%d.%d library version: %d.%d.%d\n",

FREETYPE_MAJOR,FREETYPE_MINOR,FREETYPE_PATCH,
(int)major,(int)minor,(int)patch );

if(major!=FREETYPE_MAJOR
minor!=FREETYPE_MINOR){

printf("Library and header version mismatch! Fix it in your distribution!\n");
exit(1);

}
return 0;

}

cc -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4 -march=pentium-m -mtune=pentium-m -pipe -ffast-math -fomit-frame-pointer -I/usr/local/include -I/usr/X11/include -L/usr/local/lib -liconv -lncurses -framework Carbon -framework QuickTime? -framework CoreAudio? -framework AudioUnit? -framework AudioToolbox? -framework Cocoa -framework QuartzCore? -framework OpenGL -framework IOKit -framework IOKit -framework OpenAL -o /var/folders/vY/vYgRq8PFH7WdkSKVPkq4H++++TI/-Tmp-mplayer-conf-28323-69015 /var/folders/vY/vYgRq8PFH7WdkSKVPkq4H++++TI/-Tmp-mplayer-conf-13835-69015.c -I/usr/X11/include/freetype2 -I/usr/X11/include -L/usr/X11/lib -lfreetype -lz -Wl,-framework,CoreServices?,-framework,ApplicationServices?
ld: cycle in dylib re-exports with /usr/X11/lib/libGL.dylib
collect2: ld returned 1 exit status

Result is: no
##########################################

comment:3 Changed 12 years ago by stranche@…

I found something seeming very related on some forums :
"
This is a new feature (AKA bug) in /usr/bin/ld, coupled with the fact that Apple rather stupidly chose the same name "libGL.dylib" for two linked but different libraries in /usr/X11/lib and in the OpenGL framework.

A fix is described here:
<http://wiki.finkproject.org/index.php/Fink:Packaging:Preparing_for_10.5#OpenGL_Bug>
"

comment:4 Changed 12 years ago by stranche@…

Confirmed !
the ./configure works with the following :

# LDFLAGS=-Wl,-dylib_file,/System/Library/Frameworks?/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
# ./configure

now compile works, I'll test to see if gives the result expected on the video.

Source needs a fix.

comment:5 Changed 12 years ago by stranche@…

Works, subtitles are back.

Now needs a fix for the source.
I leave as assigned since it is not fixed in the SVN tree.

comment:6 Changed 12 years ago by diego@…

  • Resolution set to wontfix
  • Status changed from assigned to closed

This is a bug in the system, not in MPlayer, hence it should be fixed in the system and not in MPlayer.

Note: See TracTickets for help on using tickets.