Opened 12 years ago

Closed 12 years ago

#941 closed defect (invalid)

mencoder segfaults with -ass enabled

Reported by: mplayer-bugs@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc2 Severity: normal
Keywords: Cc: mplayer-bugs@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Using the command

/usr/bin/mencoder file.mkv -slang en -ass -ass-font-scale 0.6 -ofps 24000/1001 -noskip -oac mp3lame -ovc xvid -xvidencopts pass=1 -vf scale=1280:720,harddup -o /dev/null

produces a segmentation fault. Removing the -ass option avoids the segmentation fault, but I am unable to rescale the subtitles contained in the Matroska file.

The build is from rpm.livna.org, mencoder-1.0-0.81.rc2.lvn7.

The list of (fulfilled) dependencies includes:
libasound.so.2
libasound.so.2(ALSA_0.9)
libasound.so.2(ALSA_0.9.0rc4)
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.1)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libcdda_interface.so.0
libcdda_paranoia.so.0
libdl.so.2
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libdts.so.0
libdv.so.4
libdvdnavmini.so.4
libdvdread.so.3
libenca.so.0
libfaac.so.0
libfontconfig.so.1
libfreetype.so.6
libfribidi.so.0
libgcc_s.so.1
libgcc_s.so.1(GCC_3.0)
libgif.so.4
libjpeg.so.62
liblirc_client.so.0
liblzo2.so.2
libm.so.6
libm.so.6(GLIBC_2.0)
libm.so.6(GLIBC_2.1)
libmp3lame.so.0
libmpcdec.so.3
libogg.so.0
libpng12.so.0
libpng12.so.0(PNG12_0)
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2)
libpthread.so.0(GLIBC_2.3.2)
libspeex.so.1
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4)
libtheora.so.0
libtheora.so.0(libtheora.so.1.0)
libtwolame.so.0
libungif.so.4
libvorbis.so.0
libx264.so.54
libxvidcore.so.4
libz.so.1
mplayer = 1.0-0.81.rc2.lvn7

Change History (2)

comment:1 Changed 12 years ago by mplayer-bugs@…

  • Cc mplayer-bugs@… added

comment:2 Changed 12 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed

i blame your binary packaged mencoder for crashing.
manually compiled mencoder will not seg fault with -ass

also, mencoder does not have -ass support yet, there is a patch on dev-eng.

also you are missing gdb output (but since you arent using svn this is unimportant)

Note: See TracTickets for help on using tickets.