Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#947 closed defect (wontfix)

mplayer crashes when it tries to play VP6 compressed movie

Reported by: selmi@… Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

file plays correctly using
mplayer -vc vp6 fmv12_generichub_english_ntsc.avi

but crashes using
mplayer -vc ffvp6 fmv12_generichub_english_ntsc.avi

unfortunately the second possibility is default, so it crashes unless you play with options

i used windows port of mplayer and i don't know how to build it there from sources, so i can't do better error report. but sample file is uploaded to upload.mplayerhq.hu, its name is vp6_crash.avi and description vp6_crash.txt

here is error message:

MPlayer Sherpya-SVN-r23404-4.2.0 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) X2 Dual Core Processor BE-2350 (Family: 15, Model: 107, Stepping: 1)
SSE supported but disabled
SSE2 supported but disabled
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Playing fmv12_generichub_english_ntsc.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
AVI: No audio stream found -> no sound.
VIDEO: [VP60] 1280x720 24bpp 29.970 fps 1683.7 kbps (205.5 kbyte/s)
SUB: Could not determine file format
Cannot load subtitles: ./fmv12_generichub_english_ntsc.txt
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffvp6] vfm: ffmpeg (FFmpeg VP6 decoder)
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [directx] 1280x720 => 1280x720 Planar YV12
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
V: 0.0 1/ 1 ??% ??% ??,?% 0 0
MPlayer interrupted by signal 11 in module: decode_video

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

btw i know its SVN revision is old, unfortunately from site there is only rc1 available for windows which is even older.... so i can't test if it now works better of not... if you will find file playable then sorry

Change History (4)

comment:1 Changed 12 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

File plays fine here. Related projects page has much newer Windows builds.

comment:2 Changed 12 years ago by selmi@…

i tried it with almost current build, MPlayer Sherpya-SVN-r25088-4.2.1
and it crashes too... :-( so maybe its something fixed only short time ago or something related to builds from http://oss.netfarm.it/mplayer-win32.php (i tried both athlon and p4 build) or its problem in my system....

comment:3 Changed 12 years ago by compn

  • Resolution changed from worksforme to wontfix

hi, this is a bug in libavcodec which is part of ffmpeg project
so i made the bugreport on their tracker, you can find it here:
https://roundup.mplayerhq.hu/roundup/ffmpeg/issue275

thanks for uploading a sample and bugreport :)

comment:4 Changed 11 years ago by compn

this bug was fixed in svn :)

Note: See TracTickets for help on using tickets.