Opened 12 years ago

Closed 12 years ago

#957 closed defect (invalid)

MPlayer Has Problem with TAP Pitch Shifter Filter

Reported by: hovh03@… Owned by: reynaldo@…
Priority: normal Component: af
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The command I use is the following.

mplayer -af ladspa=tap_pitch:tap_pitch:0:0:-90:0 -fs -fixed-vo -vf yadif=3:1 -slave -quiet -noborder -brightness 0 somevideo.mpg

It doesn't shift anything, just to demo the bug. Few of my video files work, the rest does not work with the filter. There are two problems:

1) The windows does not show up at all. Rarely, it shows up without sound.

2) When it works, and the video has two audio tracks, switch audio track will cause the filter not working in the new track. Switch back to the old audio track will also reset the audio back to the normal pitch. This is a big problem because this filter cannot be set in real time, and 2nd audio track can be switched in real time. So they don't work together, unless I know in advance (of the user intention) and set it in the command line.

Please test with a few video files to see if you can reproduce the problem. If not, I'll find a way to send you a test video file. Its size is the problem.

Change History (1)

comment:1 Changed 12 years ago by reynaldo@…

  • Resolution set to invalid
  • Status changed from new to closed

As far as I can tell this is not a bug on MPlayer but on tap-plugins.

Note: See TracTickets for help on using tickets.