Opened 12 years ago

Closed 11 years ago

#959 closed defect (wontfix)

Interlaced pictures + spatial direct mode is not implemented

Reported by: goga777@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I try to watch hdtv dvb-s/s2 h.264 channels from satellites by MPlayer and very often I have the error

[h264 @ 0x86a46b0]Interlaced pictures + spatial direct mode is not
implemented

Could you implement it ih ffmpeg/MPlayer , beacuse most of them satellites channels use tis mode

$ mplayer GOD.ts
MPlayer dev-SVN-r24811-4.1.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (Family: 15, Model: 3, Stepping: 4)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing GOD.ts.
TS file format detected.
VIDEO H264(pid=2014) AUDIO MPA(pid=3014) NO SUBS (yet)! PROGRAM N. 14
FPS seems to be: 25.000000
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 544 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.36:1 - prescaling to correct movie aspect.
VO: [xv] 544x576 => 786x576 Planar YV12
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
[h264 @ 0x88bf7f0]Interlaced pictures + spatial direct mode is not implemented
A:93701.6 V:93703.4 A-V: -1.776 ct: -0.080 21/ 21 20% 0% 0.7% 0 0
Exiting... (Quit)
_

Change History (1)

comment:1 Changed 11 years ago by r_togni@…

  • Resolution set to wontfix
  • Status changed from new to closed

The problem is in the decoder, not in the demuxer.
If the bug is still open please report to ffmpeg (even afaik they already know)

Note: See TracTickets for help on using tickets.