Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#960 closed defect (fixed)

Mplayer 0.99.11: gives errors on KLSXFM radio when 0.99.10_14 worked ok

Reported by: yuri@… Owned by: r_togni@…
Priority: very important Component: streaming
Version: unspecified Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

command that I run is: mplayer -user-agent Mozilla http://208.80.52.108/KLSXFM

Before it was just playing but now after the upgrade I get the following messages and sound doesn't come up at all.

Yuri

Playing http://208.80.52.108/KLSXFM.
Resolving 208.80.52.108 for AF_INET6...
Couldn't resolve name for AF_INET6: 208.80.52.108
Connecting to server 208.80.52.108[208.80.52.108]: 80...
Cache size set to 320 KBytes
Cache fill: 17.50% (57344 bytes)
libavformat file format detected.
[lavf] Audio stream found, -aid 0
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
mpg123: Can't rewind stream by 684 bits!
AUDIO: 22050 Hz, 2 ch, s16le, 64.0 kbit/9.07% (ratio: 8000->88200)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 22050Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
Stream not seekable!
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 81, size 693840, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 144, size 9462010, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 254, size 15645320, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 255, size 15958128, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 108, size 10708765, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 223, size 10520414, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 167, size 5432818, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 93, size 2416308, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 210, size 6679359, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 115, size 9676343, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 70, size 307100, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 109, size 8864338, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 98, size 8027855, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 78, size 13852996, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 255, size 12317063, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 250, size 5956432, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 229, size 4335430, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 61, size 14476194, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 111, size 13523372, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 187, size 6847967, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 214, size 12434361, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 26, size 11039312, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 62, size 12667590, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 70, size 9080931, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 239, size 6251829, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 247, size 12221868, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 38, size 2771524, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 227, size 12109872, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 131, size 5143138, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 44, size 15996268, flags 0
Stream not seekable!
[flv @ 0x8d1cd68]skipping flv packet: type 226, size 11091937, flags 0
Stream not seekable!

Change History (4)

comment:1 Changed 12 years ago by compn

workaround:

mplayer -rawaudio format=0x55 -demuxer rawaudio -user-agent Mozilla http://208.80.52.108/KLSXFM

ffplay (FFplay version SVN-r11006) plays the stream fine, so i dont think its a lavf bug ... hmm.

comment:2 Changed 12 years ago by yuri@…

(In reply to comment #1)
once I downgraded port multimedia/mplayer back to 0.99.10 the problem is gone.
So bug is definitely in mplayer source tree.

comment:3 Changed 11 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

Works ok with latest SVN, based on compn comment I think that it was probably fixed sometime after your report; I can't figure out what version 0.99.11 is.

Please try to upgrade if a new version is available, else you need to get the code from SVN and compile it yourself.

comment:4 Changed 11 years ago by reimar

Ah, this is the bug. I fixed this by setting is_streamed correctly in lavf demuxer, otherwise it would try to parse the whole file beforehand and get confused. It was fixed in r25500/r25506.
Could not find this bug anymore after I had fixed it ;-)

Note: See TracTickets for help on using tickets.