Opened 12 years ago

Closed 10 years ago

#970 closed defect (worksforme)

Mplayer 1.0rc2 crashes when seeking on nuv files

Reported by: bugzilla-mplayer@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc2 Severity: normal
Keywords: Cc: bugzilla-mplayer@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer 1.0rc2 crashes for me whenever I press seek (+ or -) while
playing nuv files (that I recorded previously with mythtv and
transcoded to MPEG4). Untranscoded mythtv files that are non-nuv files and are straight mpeg2 from my digital tv card play fine.

This happens both when running under Fedora8/Linux 2.6.23.9 and under the win32 running under WinXP.

I did not have this problem before with 1.0rc1 on Fedora6 or Windoze. So this seems to be a new bug introduced since rc1.

The error message I get when I run at msglevel all=6, is:

stream_seek: WARNING! Can't seek to 0x194E2DED ! 21% 1% 0.7% 14 0
ds_fill_buffer: EOF reached (stream: audio)
ds_fill_buffer: EOF reached (stream: audio)
ds_fill_buffer: EOF reached (stream: audio)
ds_fill_buffer: EOF reached (stream: audio)
ds_fill_buffer: EOF reached (stream: video)
EOF code: 1 0.0 A-V: 0.000 ct: 0.000 134/134 ??% ??% ??,?% 0 0

So any idea why seeking on nuv files (or at least mythtv recorded nuv files) seems to be broken?

Thanks

Change History (2)

comment:1 Changed 12 years ago by bugzilla-mplayer@…

(In reply to comment #0)
Note that the problem is not a codec one because I tried switching the codecs from rc1 and rc2 and the problem always occur with the rc2 version of mplayer and never with the rc1 version independent of the codec version.

Also, not sure if this is relevant, but when playing the nuv file (under rc2 before pressing seek), the aspect ratio is more stretched out and I get the following console messages:

Movie-Aspect is 3.14:1 - prescaling to correct movie aspect.
[swscaler @ 00D4AEB0]SwScaler?: using unscaled yuv420p -> rgb32 special converter

VO: [directx] 1920x1088 => 3414x1088 BGRA
[ASPECT] Warning: No suitable new res found!

When I play the same file under rc1, I get a more normal 1.76:1 (16:9) aspect ratio and the following console messages:

Movie-Aspect is 3.14:1 - prescaling to correct movie aspect.
[swscaler @ 00D4AEB0]SwScaler?: using unscaled yuv420p -> rgb32 special converter

VO: [directx] 1920x1088 => 3414x1088 BGRA
[ASPECT] Warning: No suitable new res found!

comment:2 Changed 10 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

no crash here in svn seeking/playing with these samples:
http://samples.mplayerhq.hu/nuv/

please reopen if you have a sample that crashes.

Note: See TracTickets for help on using tickets.