Opened 11 years ago

Closed 11 years ago

#983 closed defect (fixed)

MPlayer can't play .au file (Signed 8 bit PCM, mono, 44100Hz)

Reported by: mgarski@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have uploaded sample .au file that are unsupported. vrooom.txt file include verbose MPlayer output.

Change History (3)

comment:1 Changed 11 years ago by r_togni@…

Bug confirmed, ffplay has the same problem (should be related to audio codec mapping).
Sample moved to samples/au

comment:2 Changed 11 years ago by mgarski@…

MPlayer revision 25795, still can't play vrooom.au file, but output different messages:
Playing vrooom.au.

Cache fill: 4.17% (81920 bytes)
Cache fill: 5.43% (106824 bytes)
libavformat file format detected.
[lavf] Audio stream found, -aid 0
==========================================================================
Opening audio decoder: [msadpcm] MS ADPCM audio decoder
AUDIO: 44100 Hz, 1 ch, s16le, 0.0 kbit/0.00% (ratio: 0->88200)
Selected audio codec: [msadpcm] afm: msadpcm (MS ADPCM)
==========================================================================
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: -0.0 (unknown) of 0.0 (unknown) ??,?% 0% [J
[lots of above messages]
MS ADPCM: coefficient (255) out of range (should be [0..6])
[this one too]

comment:3 Changed 11 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

The change of behaviour is because I already fixed the libavformat part.
The MPlayer part is fixed in r25817.

Note: See TracTickets for help on using tickets.