Opened 12 years ago

Closed 10 years ago

#986 closed enhancement (duplicate)

Mencoder ASS subtitle support

Reported by: chris@… Owned by: eugeni.stepanov@…
Priority: if idle Component: core
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I discovered that attempting to use mencoder to re-encode matroska files with ASS subtitle streams crashed mencoder due to the ASS library not being initialized in mencoder.c.

mencoder -ass -sid 0 "source-video.mkv" -v -ofps 15 -sws 9 -vf format=rgb24,scale=256:192:::3 -nosound -ovc lavc -lavcopts vcodec=mpeg1video:vstrict=-2:mbd=2:trell:cbp:mv0:cmp=2:subcmp=2:precmp=2:vbitrate=256 -o mpgtmp.mpg -of rawvideo

It works fine if I leave out the "-ass" option, but it doesn't use the nice ASS library support that mplayer has. I tried to add support myself to mencoder, but I haven't learned enough about mplayer's/mencoder's core to set up the plugin/filter correctly like they are in mplayer. The crash stopped just by initializing ASS in mencoder.c, but it won't render anything without all the other filter setup. My attempts to clone how mplayer does it have failed to produce any results.

Change History (4)

comment:1 Changed 12 years ago by eugeni.stepanov@…

  • Status changed from new to assigned

comment:2 Changed 12 years ago by eugeni.stepanov@…

  • Owner changed from Reimar.Doeffinger@… to eugeni.stepanov@…
  • Status changed from assigned to new

comment:3 Changed 12 years ago by eugeni.stepanov@…

  • Priority changed from normal to if idle
  • Status changed from new to assigned

The problem is, in mencoder pts are not passed into the filter chain. If turned on, something might break, I'm not sure what exactly, and I can't guarantee that there will be no regressions. If this problem is solved somehow, adding ASS support to mencoder would be easy.

One possible solution is to enable pts in mencoder with -ass option. This could result in unrelated filters/encoders changing behaviour based on -ass option, which is not a good thing and can be very confusing for users.

comment:4 Changed 10 years ago by compn

  • Resolution set to duplicate
  • Status changed from assigned to closed

ass mencoder sub patch at bug 1401

* This bug has been marked as a duplicate of bug 1401 *

Note: See TracTickets for help on using tickets.