Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#987 closed defect (fixed)

Advanced SubStation Alpha ass rendering weirdness

Reported by: physhii@… Owned by: eugeni.stepanov@…
Priority: normal Component: vf
Version: unspecified Severity: trivial
Keywords: Cc: physhii@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

As of svn 25659 and versions down to 1.0rc2 I get strange ASS rendering when using the font in this style:
Format: Name, Fontname, Fontsize, PrimaryColour?, SecondaryColour?, OutlineColour?, BackColour?, Bold, Italic, Underline, StrikeOut?, ScaleX, ScaleY, Spacing, Angle, BorderStyle?, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, Encoding
Style: SpicyWolf?,Cambria,40,&H00FFFFFF,&H000000FF,&H3C533727,&H50342720,0,0,0,0,105,100,0,0,1,1.6,1.5,2,15,15,15,0

Font is likely the cause of the problem as when changed to something else such as Ampersand - the weird vertical spacing goes away.

Here's a two screens - one of how it currently looks, and how it should look using vsfilter:
http://www.phyquality.net/advancedsubstationweirdness.jpg
http://www.phyquality.net/advancedsubstationvsfilter.jpg

Here's the files used in the video:
http://www.phyquality.net/spice.ass
http://www.phyquality.net/cambria.ttc
http://www.phyquality.net/ampersand.ttf
http://www.phyquality.net/Caramella_Regular.ttf

Change History (5)

comment:1 Changed 12 years ago by eugeni.stepanov@…

  • Status changed from new to assigned

comment:2 Changed 12 years ago by eugeni.stepanov@…

  • Owner changed from Reimar.Doeffinger@… to eugeni.stepanov@…
  • Status changed from assigned to new

Reproduced. I take a look at it shortly.

comment:3 Changed 12 years ago by eugeni.stepanov@…

  • Status changed from new to assigned

comment:4 Changed 12 years ago by eugeni.stepanov@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r25688.

comment:5 Changed 12 years ago by physhii@…

Thanks for the fix. :)

Note: See TracTickets for help on using tickets.