Opened 11 years ago

Closed 11 years ago

#989 closed defect (invalid)

ASS filter fails to render effects on certain characters

Reported by: physhii@… Owned by: eugeni.stepanov@…
Priority: normal Component: libass
Version: unspecified Severity: trivial
Keywords: Cc: physhii@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

As of 1.0rc2 to revision 25746, the character 'b' in the font "Shana.ttf" fails to render correctly as shown here:
http://www.phyquality.net/shaku.jpg

Files used in video:
http://www.phyquality.net/shana.ass
http://www.phyquality.net/Shana.ttf

Attachments (2)

revert-font-size-hack.patch (1.2 KB) - added by eugeni.stepanov@… 11 years ago.
Reverts font size hack that is only done for freetype >= 2.2.0
1.png (903.3 KB) - added by eugeni.stepanov@… 11 years ago.
screenshot with 2.1.10

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by reimar

  • Owner changed from Reimar.Doeffinger@… to eugeni.stepanov@…

ASS is not my area...

comment:2 Changed 11 years ago by physhii@…

What component should I be assigning this to?

comment:3 Changed 11 years ago by eugeni.stepanov@…

  • Status changed from new to assigned

Works for me. There was a similar problem once, related to not cleaning some memory. Such things usually depend on subtitle display order.

This time, if I just play the first 3 subs, all characters are display fine. Are you sure you did not do some seeking in the file before this happened ?

comment:4 Changed 11 years ago by eugeni.stepanov@…

  • Component changed from vf to libass

Switching this to the newly added "libass" component.

comment:5 Changed 11 years ago by physhii@…

After looking into it some more, testing different types of theories, I
discovered that it simply does not like my favorite version of
libfreetype.so.6.3.16 - Gentoo's media-libs/freetype-2.1.10 - I upgraded to the
latest version and it seems to be working fine now. I prefer that old lib
because it renders my favorite font in a way that I like.

Changed 11 years ago by eugeni.stepanov@…

Reverts font size hack that is only done for freetype >= 2.2.0

comment:6 Changed 11 years ago by eugeni.stepanov@…

Please check if the attached patch restores the buggy behavior with the latest freetype.

comment:7 Changed 11 years ago by physhii@…

Does not restore behavior.

comment:8 Changed 11 years ago by eugeni.stepanov@…

Ok, I reproduced it with FreeType? 2.1.10.
There _is_ some outline around 'b', but it is very weird. Seems like a FreeType? bug.
Seeing that this problem is fixed in the latest FreeType?, making a workaround is not worth the effort (and it seems almost impossible).

Changed 11 years ago by eugeni.stepanov@…

screenshot with 2.1.10

comment:9 Changed 11 years ago by eugeni.stepanov@…

comment:10 Changed 11 years ago by eugeni.stepanov@…

  • Resolution set to invalid
  • Status changed from assigned to closed

closing

Note: See TracTickets for help on using tickets.