Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#992 closed enhancement (fixed)

enhance -panscan option for 4:3 material on 16:10 displays

Reported by: lars.taeuber@… Owned by: reimar
Priority: unimportant Component: vo
Version: unspecified Severity: minor
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hallo,

I'm now the proud owner of a 16:10 display. Because I have several 4:3 video material I'd like to use the »-panscan« option also for cutting of top and button parts of 4:3 video to zoom in.
Is this possible with the logic behind this panscan option?

Thanks
Lars

Change History (7)

comment:1 Changed 12 years ago by reimar

  • Cc Reimar.Doeffinger@… added
  • Owner changed from beastd to Reimar.Doeffinger@…

That is completely normal behaviour for panscan, but by default you usually have to crop before you can use panscan.
See -panscanrange if you want to do without cropping.

comment:2 Changed 12 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

At least I have been able to crop to and bottom, so closing.
If you cannot get it to work, provide details.

comment:3 Changed 12 years ago by lars.taeuber@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I think you might have misunderstood me.

When I watch a 16:9 video on a 4:3 display and I use the »-panscan« option then left and right parts of the video get cropped so there are no black parts left on the screen.

I asked for an enhancement so that 4:3 video gets autmatically cropped at top and bottom with the panscan option on a 16:9 display.

I know this could be done with other (cropping) options, but this is true for the behaviour of panscan too. I thought the panscan option was introduced to simplify this.

Lars

comment:4 Changed 12 years ago by reimar

  • Resolution set to fixed
  • Status changed from reopened to closed

Ah. Well, I just use negative panscanrange values and adjust it during playback, seems much simpler to me.
But anyway, implemented in SVN r25810.

comment:5 Changed 12 years ago by lars.taeuber@…

The problem with negative panscanrange is that you don't know the exact value to use. With panscanrange=1 you use panscan with values between 0 and 100% for scaling.

But I see this seems to be no a valuable feature to be added.

I had a short look at the aspect.c file and think the aspect function could choose the »pandirection« depending on the relation of display_asr to video_asr. But I'm not a programmer.

(scrw/scrh)*monitor_pixel_aspect : (prew/preh)

Thanks anyway.
Lars

comment:6 Changed 12 years ago by reimar

Huh? I said I implemented it in r25810, say if that's not what you expected.

comment:7 Changed 12 years ago by lars.taeuber@…

Sorry I missed that.

Thanks alot and best regards.
Lars

Note: See TracTickets for help on using tickets.