Opened 11 years ago

Closed 8 years ago

#994 closed defect (wontfix)

Unimplemented resampler for mode

Reported by: arekm@… Owned by: reimar
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

As requested, here is my "contact". It happens when watching dvd movie with DD 2.0 audio. Do you need more info?

Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Unimplemented resampler for mode 0x2 -> 6 channels conversion - Contact MPlayer developers!
Unimplemented resampler for mode 0x2 -> 5 channels conversion - Contact MPlayer developers!
Unimplemented resampler for mode 0x2 -> 4 channels conversion - Contact MPlayer developers!
Unimplemented resampler for mode 0x2 -> 3 channels conversion - Contact MPlayer developers!
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...

Change History (7)

comment:1 Changed 11 years ago by compn

yes, can you make a small sample of your file and upload it to ftp://upload.mplayerhq.hu/MPlayer/incoming ?

5-10mb is preferred, thanks! (make sure the small sample also gives same errors before uploading)

comment:2 Changed 11 years ago by arekm@…

This happens for real DVD (mplayer dvd://2).

I unfortunately don't know how to fetch only that part 2 (with appropriate audio path) into small 20MB size. dding /dev/dvd would need much more than 20MB to get even start of that 2 part.

Any hints?

comment:3 Changed 11 years ago by arekm@…

I have another one:
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Unimplemented resampler for mode 0xA -> 6 channels conversion - Contact MPlayer developers!
Unimplemented resampler for mode 0xA -> 5 channels conversion - Contact MPlayer developers!
Unimplemented resampler for mode 0xA -> 4 channels conversion - Contact MPlayer developers!
Unimplemented resampler for mode 0xA -> 3 channels conversion - Contact MPlayer developers!
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)

uploaded as Unimplemented_resampler_for_mode_0xA.avi

comment:4 Changed 11 years ago by compn

(In reply to comment #2)

This happens for real DVD (mplayer dvd://2).

I unfortunately don't know how to fetch only that part 2 (with appropriate
audio path) into small 20MB size. dding /dev/dvd would need much more than 20MB
to get even start of that 2 part.

Any hints?

mplayer dvd://2 -dumpstream and just kill mplayer after a few seconds

it should work :)

comment:5 Changed 11 years ago by arekm@…

Unfortunately stream dumped this way is played without "Unimplemented resampler for mode " warning :-/

comment:6 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:7 Changed 8 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

This seems to be liba52 code, and MPlayer no longer uses that by default.
Thus I think this is now obsolete, though it not happening with -dumpsteam sample is strange (though there are a few possibilities like it choosing a different audio stream, -channels 6 only used for DVDs or something else).

Note: See TracTickets for help on using tickets.