Opened 12 years ago

Closed 12 years ago

#997 closed defect (fixed)

MPlayer can't play .aif file (16 bit BE, mono, 22050Hz)

Reported by: mgarski@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have uploaded sample .aif file that are unsupported.

MPlayer SVN trunk revision 25819 verbose output:

MPlayer dev-SVN-rUNKNOWN-4.1.2 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (Family: 15, Model: 35, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
get_path('codecs.conf') -> '/home/pawel/.mplayer/codecs.conf'
Reading /home/pawel/.mplayer/codecs.conf: Can't open '/home/pawel/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayercodecs.conf: Can't open '/etc/mplayercodecs.conf': No such file or directory
Using built-in default codecs.conf.
Configuration: --prefix=/usr --datadir=/usr/share/mplayer/ --confdir=/etc/mplayer/ --mandir=/usr/share/man --libdir=/usr/lib64 --enable-largefiles --enable-menu --enable-xvmc
CommandLine?: '-v' 'dragon.aif'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> '/home/pawel/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/home/pawel/.mplayer/input.conf'
Can't open input config file /home/pawel/.mplayer/input.conf: No such file or directory
Can't open input config file /etc/mplayerinput.conf: No such file or directory
Falling back on default (hardcoded) input config
get_path('dragon.aif.conf') -> '/home/pawel/.mplayer/dragon.aif.conf'

Playing dragon.aif.
get_path('sub/') -> '/home/pawel/.mplayer/sub/'
[file] File size is 131784 bytes
STREAM: [file] dragon.aif
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0 pre:393216 eof:0

Cache fill: 0.00% (0 bytes)
Cache fill: 6.70% (131784 bytes)
LAVF_check: Audio IFF
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename dragon.aif ext: .aif
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 79
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 67615, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=17999 size=131766
LMLM4 Stream Format not found
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 2 p101: 3 p1B6: 0 p12x: 1 sli: 3 a: 0 b: 0 c: 0 idr: 1 sps: 0 pps: 0 PES: 0 MP3: 86, synced: 0
MPEG-ES file format detected.
==> Found video stream: 0
Searching for sequence header... ds_fill_buffer: EOF reached (stream: video)
NONE :(
MPEG: FATAL: EOF while searching for sequence header.
Video: Cannot read properties.
No stream found.

vo: x11 uninit called but X11 not inited..

Exiting... (End of file)

Change History (3)

comment:1 Changed 12 years ago by r_togni@…

The problem is in the MPEG ES demuxer that misdetects the file as its own format, and this prevents the correct demuxer to test the file. I forwarded the bug to the development mailing list to the mpeges demuxer mantainer.
The file works if you add -demuxer lavf to force the correct demuxer selection.

Is the file supposed to sound like a machine gun? Can you confirm that the file sounds ok if you force the demuxer selection?

Sample moved to samples/aiff

comment:2 Changed 12 years ago by mgarski@…

Is the file supposed to sound like a machine gun? Can you confirm that the file
sounds ok if you force the demuxer selection?

Yes, it sound like a machine gun, and works with forced demuxer.

comment:3 Changed 12 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by nico in r25866

Note: See TracTickets for help on using tickets.