Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#135 closed defect (fixed)

skin contents change but filenames stay the same

Reported by: ben@… Owned by: diego@…
Priority: normal Component: GUI
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When the content of distribution files change, but the distribution filename
remains the same, this causes problems for automated build systems such as
NetBSD's pkgsrc. It is desirable to bump the version number in the
distribution filename, so that the files may be distinguished from each other
by name.

The files in question are the gmplayer skin files. Recently the AlienMind? and
Blue skins changed, but the distribution filenames did not. For other
examples, see the commit messages in the following links:

http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/multimedia/gmplayer/distinfo?
rev=1.17&content-type=text/x-cvsweb-markup

http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/multimedia/gmplayer/distinfo?
rev=1.15&content-type=text/x-cvsweb-markup

http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/multimedia/gmplayer/distinfo?
rev=1.14&content-type=text/x-cvsweb-markup

http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/graphics/gmplayer/Attic/distinfo?
rev=1.26&content-type=text/x-cvsweb-markup

http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/graphics/gmplayer/Attic/distinfo?
rev=1.17&content-type=text/x-cvsweb-markup

Change History (6)

comment:1 Changed 11 years ago by diego@…

  • Component changed from core to GUI
  • Owner changed from alex@… to diego@…
  • Summary changed from distribution contents change but filenames stay the same to skin contents change but filenames stay the same

comment:2 Changed 11 years ago by diego@…

  • Status changed from new to assigned

Please explain your problem in greater detail. The skin tarballs do include
version numbers.

comment:3 Changed 11 years ago by diego@…

  • Resolution set to invalid
  • Status changed from assigned to closed

No explanation received, no bug identifiable, marking INVALID.

comment:4 Changed 11 years ago by ben@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

There are version numbers in the skin archive names. The problem is
that the contents of the skin archive names will sometimes change, while
the version number remains the same.


Hmm, this should not (have) happen(ed). Can you give an example?

The last time I noticed this happen, the contents of the archives were
different, but the extracted arhive members were not different. For example
mplayer/Skin/AlienMind-1.2.tar.bz2: on Oct 6 the md5 checksum was
0aa36c896bf7ca3339fce265d3cd5ce1, and on Oct 30 it was
1fb83948e02c3a8b9e01d8219aece615.

You can see my copies of the distfiles at:
http://backyard.homeunix.net/~ben/mplayer/

Cheers,

Ben

comment:5 Changed 11 years ago by diego@…

You have me mystified. If you look at the skins CVS at

http://www.mplayerhq.hu/cgi-bin/cvsweb.cgi/skins/AlienMind/

you will notice that AlienMind? has not been updated in almost a year. I have no
idea what might cause the MD5 sum mismatch. Could you please investigate what
the exact difference between those two packages is?

Anyway, from now on I will bump the version number even for small changes. Does
that satisfy you?

comment:6 Changed 11 years ago by ben@…

  • Resolution set to fixed
  • Status changed from reopened to closed

The last time I noticed this happen, the archive members themselves had not
changed. I think someone must have given different options to bzip2, because if
you look at the first 16 bytes of the archives, they immediately differ after
the 10 byte bzip2 header. The place where they begin to differ is in the stored
block CRC, for the first block.

-00000000 42 5a 68 39 31 41 59 26 53 59 96 f9 d0 73 00 4c |BZh91AY&SY...s.L|
+00000000 42 5a 68 39 31 41 59 26 53 59 78 e6 69 c0 00 4c |BZh91AY&SYx.i..L|

In previous times, I actually saw changes in the archive members themselves.
Unfortunately, I do not have copies of the archives from that time.

Yes, it will satisfy me if from now on you bump the version number even for
small changes. Thank you very much!

Ben

Note: See TracTickets for help on using tickets.