Opened 6 years ago

Closed 6 years ago

#1774 closed defect (invalid)

top 16 rows of a portrait theora video frame are corrupted (even with -vo png)

Reported by: timo.lindfors@… Owned by: reimar
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Steps to reproduce:
1) mplayer -vo png testcase1.ogv
2) look at 00000001.png

Expected results:
2) The title of the presentation is a contiguous yellow area as can be seen in the attached file working1.png

Actual results:
2) The title of the presentation is not contiguous. The top 16 rows of the video are somehow corrupted and contain copies of other parts of the frame. See the attached file broken1.png

More info:
1) I am building mplayer on debian unstable.
2) This occurs with svn revision 31442
2.2) This does not occur with svn revision 31150
2.3) Bisecting shows that the first broken revision is 31225:

r31225 | reimar | 2010-05-26 14:01:38 -0400 (Wed, 26 May 2010) | 4 lines

Switch ogg demuxing to lavf by default.
This has the side-effect of using fftheora by default instead of
theora, which possibly should be changed.

Adding vc=theora to the command line does not seem to help so the issue is not appear to be caused by the switch from theora to fftheora. However, adding -demuxer ogg seems to help.

3) The kernel is
$ uname -a
Linux lindi1 2.6.32-5-amd64 #1 SMP Thu Aug 12 13:01:50 UTC 2010 x86_64 GNU/Linux
4) This occurs also on ARM
5) libc is
$ /lib/libc.so.6 --version
GNU C Library (Debian EGLIBC 2.11.2-2) stable release version 2.11.2, by Roland McGrath? et al.
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
Compiled by GNU CC version 4.4.4.
Compiled on a Linux 2.6.32 system on 2010-06-24.
Available extensions:

crypt add-on version 2.1 by Michael Glad and others
GNU Libidn by Simon Josefsson
Native POSIX Threads Library by Ulrich Drepper et al
BIND-8.2.3-T5B

For bug reporting instructions, please see:
<http://www.debian.org/Bugs/>.
6) compiler is
$ gcc --version
gcc-4.4.real (Debian 4.4.4-9) 4.4.5 20100816 (prerelease)
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
7) linker is
$ ld --version
GNU gold (GNU Binutils for Debian 2.20.1-system.20100303) 1.9
Copyright 2008 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or (at your option) a later version.
This program has absolutely no warranty.
8) assembler is
$ as --version
GNU assembler (GNU Binutils for Debian) 2.20.1-system.20100303
Copyright 2009 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `x86_64-linux-gnu'.

Attachments (3)

testcase1.ogv (250.0 KB) - added by timo.lindfors@… 6 years ago.
testcase video to reproduce the bug (first 250KB)
working1.png (225.7 KB) - added by timo.lindfors@… 6 years ago.
example of working case
broken1.png (226.1 KB) - added by timo.lindfors@… 6 years ago.
example of broken failing case

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by timo.lindfors@…

testcase video to reproduce the bug (first 250KB)

comment:1 Changed 6 years ago by timo.lindfors@…

Changed 6 years ago by timo.lindfors@…

example of working case

comment:2 Changed 6 years ago by timo.lindfors@…

Changed 6 years ago by timo.lindfors@…

example of broken failing case

comment:3 Changed 6 years ago by timo.lindfors@…

comment:4 Changed 6 years ago by reimar

-noslices "fixes" it. It would be good to test ffmpeg/ffplay whether it has issues or not, though I do not know if they actually use slices.

comment:5 Changed 6 years ago by diego@…

  • Cc diego@… added
  • op_sys changed from Linux to All
  • rep_platform changed from PC (x86_64) to All

I can reproduce on OS X / PPC and ffplay works without problems for me.

comment:6 Changed 6 years ago by reimar

I fear MPlayer may be the only application using slices... Though maybe ffmpeg with libavfilter can/will use slices...

comment:7 Changed 6 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug in MPlayer.
Fixed in FFmpeg SVN r25052.

Note: See TracTickets for help on using tickets.